NVP-vProxy: Niepowodzenie tworzenia kopii zapasowej "Klient 'vCenter' nie jest prawidłowo skonfigurowany na serwerze NetWorker"

Summary: Nie można utworzyć kopii zapasowej maszyn wirtualnych (VM) przy użyciu rozwiązania NetWorker VMware Protection (NVP) vProxy. Tworzenie kopii zapasowej kończy się niepowodzeniem, zgłaszając, że vCenter nie jest prawidłowo skonfigurowane na serwerze NetWorker. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wszystkie zasoby klienta vCenter zostały usunięte.

Wszystkie kopie zapasowe vProxy nie powiodły się z błędem:
MM/DD/YYYY HH:mm:SS Backup failed.
MM/DD/YYYY HH:mm:SS Unable to process VM 'vmname': Client 'vcenter' is not properly configured on the NetWorker Server or 'vcenter'(if not a virtual host) is not in the aliases list for client 'networker server'
MM/DD/YYYY HH:mm:SS vmname: Backup failed.
MM/DD/YYYY HH:mm:SS Final Summary of VMs: 
MM/DD/YYYY HH:mm:SS 0 canceled backups
MM/DD/YYYY HH:mm:SS X failed backups
MM/DD/YYYY HH:mm:SS 0 successful backups
MM/DD/YYYY HH:mm:SS 0 waiting backups
MM/DD/YYYY HH:mm:SS 0 running backups
MM/DD/YYYY HH:mm:SS 0 savesets output to next action
MM/DD/YYYY HH:mm:SS Action has finished with failures.
MM/DD/YYYY HH:mm:SS Action backup vmware-vproxy 'Backup' with job id jobid is exiting with status 'failed', exit code 1

Cause

Zasób klienta vCenter nie istnieje w NetWorker. Wszystkie zasoby klienta vCenter zostały usunięte z NMC z przekonania, że vCenter nie jest potrzebne do tworzenia kopii zapasowej.

Resolution

NetWorker VMware Protection (NVP) używa jednego zasobu klienta dla każdego VMware vCenter skonfigurowanego w NetWorker. Kopie zapasowe maszyn wirtualnych są wyświetlane jako zestawy zapisu w zasobie klienta vCenter. Oto przykład wyświetlania kopii zapasowej maszyny wirtualnej w bazie danych nośników NetWorker.
vm:vmware-vm-uuid:vcentername

Przykład:

[root@nsr ~]# mminfo -kvot
 volume        type   client           date     time         size ssid      fl   lvl name
ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/19/2025 06:00:18 PM 94 GB 4191895152 cr full vm:503e178f-6982-0b07-36b2-c46c6d3ec4c9:vcsa.amer.lan
ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:25 PM 41 GB 4259072246 cr full vm:503edaab-e481-b0e7-1433-835e23dd2a5d:vcsa.amer.lan
ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:26 PM 94 GB 4242295030 cr full vm:503e178f-6982-0b07-36b2-c46c6d3ec4c9:vcsa.amer.lan
ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:27 PM 188 GB 4225517814 cr full vm:503e7439-7053-9fc0-6c26-02f5f021b289:vcsa.amer.lan

Zasobu klienta vCenter nie należy usuwać z NetWorker. Utwórz ponownie wszystkie zasoby klienta vCenter i wznów tworzenie kopii zapasowych.

Utwórz nowego klienta w NMC dla vCenter, używając w pełni kwalifikowanej nazwy vCenter.

  1. Otwórz wiersz polecenia administratora lub sesję SSH root na serwerze NetWorker.
  2. Wprowadź monit nsradmin :
nsradmin
  1. W wierszu polecenia nsradmin użyj polecenia create type, aby utworzyć nowy zasób klienta dla serwera vCenter Server przy użyciu jego w pełni kwalifikowanej nazwy domeny (FQDN):
create type: nsr client; name: <VCENTER_FQDN>; backup type: vProxy
Przykład:
nsradmin> create type: nsr client; name: vcsa.amer.lan; backup type: vProxy
                        type: NSR client;
                        name: vcsa.amer.lan;
                 backup type: vProxy;
Create? y
created resource id 52.0.169.11.0.0.0.0.218.150.219.103.192.168.9.150(1)
nsradmin>
  1. Spróbuj ponownie wykonać kopie zapasowe.

Jeśli problem będzie nadal występował, należy usunąć zasób monitora maszyny wirtualnej (vCenter) z NetWorker i dodać go ponownie. NetWorker: Usuwanie wpisu vCenter z NMC VMware View/Removing NSR Hypervisor

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000034174
Article Type: Solution
Last Modified: 20 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.