NVP-vProxy:バックアップが失敗します - 仮想ディスク「ハードディスク 1」をバックアップできません - ソース VMDK を開くことができませんでした

Summary: NetWorker VMware Protection統合は、vProxyアプライアンスを使用して構成されています。仮想マシンのバックアップが、環境内で完了できません。  NetWorker管理コンソールのメッセージでは、単に仮想ディスクの「ハード ディスク1」をバックアップできないことを示しています。vProxyアプライアンスをホストするESXホストでHBAに問題があり、バックアップの実行に必要なディスク情報を取得できません。vProxyアプライアンスが存在するESXホストを調査します。必要に応じて、または回避策として、vProxyアプライアンスを別のESXホストにvMotionで移動します。 ​​​​ ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker VMware Protection統合は、vProxyアプライアンスを使用して構成されています。仮想マシンのバックアップが、環境内で完了できません。  NetWorker管理コンソールのメッセージでは、単に仮想ディスクの「ハード ディスク1」をバックアップできないことを示しています。
 
kA2f1000000KAxbCAG_3_0
図1: 失敗したVMバックアップのバックアップ アクション メッセージ。

vProxy vbackupd-engine.logファイルとNetWorkerサーバーのバックアップ ログには、次のように表示されます。
YYYY/MM/DD HH:MM:SS TRACE:  [43] Opening source VMDK "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk" ...
YYYY/MM/DD HH:MM:SS INFO:   [43] Calling VixDiskLib_Open("[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk")...
YYYY/MM/DD HH:MM:SS ERROR:  [43] VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR:  [43] Failed to open source VMDK "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk".
YYYY/MM/DD HH:MM:SS ERROR:  [43] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk" in "hotadd:nbd" mode.
YYYY/MM/DD HH:MM:SS ERROR:  [43] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk" in "hotadd:nbd" mode.
YYYY/MM/DD HH:MM:SS ERROR:  [43] "Hard disk 1": BackupVmdk: Failed backup.
YYYY/MM/DD HH:MM:SS ERROR:  [43] Unable to backup virtual disk "Hard disk 1".

vProxy vbackupd-vddk.logファイルには、次のように表示されます。
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO YYYY-MM-DDTHH:MM:SS error -[7F4EE8059700] [Originator@6876 sub=transport] Reconfigure attempt failed for VM "vm-123" with Vmomi::MethodFault::Exception ("vim.fault.InvalidDeviceSpec")
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO YYYY-MM-DDTHH:MM:SS error -[7F4EFC315740] [Originator@6876 sub=transport] Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO YYYY-MM-DDTHH:MM:SS error -[7F4EFC315740] [Originator@6876 sub=transport] Cannot use mode hotadd to access [DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk: Cannot mount using this method. (Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.)
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: Unable to locate appropriate transport mode to open disk. Error 13 (You do not have access rights to this file) (Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.) at 4905.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk. Error 13 (You do not have access rights to this file) (Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.) at 5026.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk. Error 13 (You do not have access rights to this file) at 5064.

Cause

vProxyアプライアンスを実行しているESXiホストで、ホスト バス アダプター(HBA)に問題があり、バックアップの実行に必要なディスク情報を取得できません。  デバイス仕様に無効な値が含まれているために仮想マシンの構成が失敗した場合、VMware Virtual Disk Development Kit (VDDK) InvalidDeviceSpec例外がスローされます。

Resolution

vProxyアプライアンスが存在するESXiホストでHBAの問題がないか調査します。必要に応じてVMwareサポートに連絡してください

回避策
vProxyアプライアンスを別のESXiホストにvMotionで移動

Additional Information

vProxy vbackupd-vddk.logおよびvbackupd-engine.logファイルは、vProxyの/opt/emc/vproxy/runtime/logs/vbackupd/ディレクトリーにあります。

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000035425
Article Type: Solution
Last Modified: 02 Nov 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.