NetWorker Administrator Account Unable to See/Manage Resources in NMC or NWUI

Summary: ALL resources (Clients, Groups, Policies, Devices, and so forth) appear to be missing in the NMC. The NMC's monitoring window is blank. nsradmin and nsrwatch confirm that the server resources still exist and the NetWorker server is still performing operations. ...

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Symptoms

ALL resources (Clients, Groups, Policies, Devices, and so forth) appear to be missing in the NetWorker Management Console (NMC) or the NetWorker Web User Interface (NWUI):
Resource tabs in NMC show no resources
NMC monitoring window is blank:
NMC Monitoring tab shows no information when logged in as Administrator

The Administrator account can see the NetWorker Server Resource (NSR) User Groups in the Server->User Groups tab:

NSR User Groups tab lists the NetWorker Usergroups
 
NOTE: If the NSR User Groups are not visible, it is possible that the Administrator users have also lost "Security Administrator" privileges. The steps outlined in the Resolution field also add the default Administrators group back to the Security Administrators user group if they were removed.

Cause

The distinguished name (DN) of the local administrator's group was removed from the external roles field of the NetWorker server's "Application Administrators" user group.

[root@nsr ~]# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> show name; external roles
nsradmin> print type: nsr usergroup; name: application administrators
                        name: Application Administrators;
              external roles: ;
nsradmin>


The user group Application Administrators should have a default external roles entry for the NetWorker server's Administrators group. For example: CN=Administrators,CN=Groups,CN=NETWORKER_SERVER_NAME,DC=DOMAIN_COMPONENT1,DC=DOMAIN_COMPONENT2

NOTE: Removing the default local Administrators group DN from the external roles fields of the Application Administrators NSR user group causes the symptoms described in this article. The NetWorker server's /nsr/logs/rap.log may show which user modified this field to remove the default settings.

Resolution

First, confirm that the NetWorker server resources still exist. 

1. Confirm if you can still see server resources using the nsradmin visual interface:
a) Open an administrator/root command prompt on the NetWorker server run: nsradmin
b) Enter: visual
c) This opens a CLI visual interface, you can use ESC and TAB to navigate around the menu and select different resources. 
Example:
C:\>nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> visual
Command: [Select]  Next   Prev   Edit   Create   Delete   Options   Quit
Select a resource type to be displayed.

                        type:  [NSR]   NSR auditlog    NSR client    NSR client fix    NSR ConnectEMC    NSR Data Domain    NSR device    NSR directive
                                NSR label    NSR license    NSR lockbox    NSR NAS discovery task    NSR notification    NSR policy    NSR pool
                                NSR Protection Group    NSR Protection Policy    NSR Report Home    NSR restricted data zone    NSR schedule    NSR service
                                NSR Snapshot Policy    NSR stage    NSR Storage Node    NSR task    NSR usergroup

2. Confirm that NetWorker server operations are visible using nsrwatch (dependent on server's scheduled operations). Open an administrator command prompt or root shell on the NetWorker server, run: nsrwatch
nsrwatch command shows devices, sessions (if running), and log messages
NOTE: Depending on your NetWorker server's scheduled operations, there may be no running sessions. You should see the server overview, device information, and messages indicating recent activity.

If the above commands confirm that the NetWorker server is still operational, proceed with the steps outlined below.
 
WARNING: If the above commands indicate that NetWorker resources are missing, or that the server is not operating, then there is likely a different issue. Contact Dell NetWorker support for assistance.
 

Correct the Application Administrators External Roles Settings.

1. Confirm which host is the AUTHC server.
 
NMC Server:
Linux: /opt/lgtonmc/etc/gstd.conf
Windows: <INSTALL_DRIVE>:\Program Files\EMC NetWorker\Management\GST\etc\gstd.conf

This file contains a string authsvc_hostname which is the AUTHC host used by the NMC.
 
NWUI Server:
Linux: /opt/nwui/logs/install.log
Windows: <INSTALL_DRIVE>:\Program Files\EMC NetWorker\nwui\logs\install.log

The install.log contains lines showing what host was set as the "Authentication server" during the NWUI initial configuration.
 
2. Open an administrative command prompt or root shell on the NetWorker server.
3. Enter: nsraddadmin -H AUTHC_SERVER_NAME -p 9090
NOTE: Replace AUTHC_SERVER_NAME with the AUTHC server hostname/address determined in step 1.
Example:
[root@nsr ~]# nsraddadmin -H nsr.amer.lan -P 9090
134749:nsraddadmin: 'cn=Administrators,cn=Groups,dc=nsr,dc=amer,dc=lan' is already on the 'external roles' list of 'Security Administrators' user group.
134751:nsraddadmin: Added role 'cn=Administrators,cn=Groups,dc=nsr,dc=amer,dc=lan' to the 'Application Administrators' user group.
134749:nsraddadmin: 'cn=Users,cn=Groups,dc=nsr,dc=amer,dc=lan' is already on the 'external roles' list of 'Users' user group.

If the field was updated correctly, NMC resources and settings should now be visible.

Additional Information

As an alternative to the command-line method shown in the Resolution field, the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) can be used to correct the Application Administrators external roles.

 
1. Log in to the NMC or NWUI using the default NetWorker Administrator account.
2. Go to Servers->User Groups.
 
NMC:
1. Open the Application Administrators user group.
2. In the User Group Properties, click the sign next to the External Roles field.
3. Select the default Administrators group.
Adding the default Administrators group back to the Application Administrators external roles

4. Click OK.
5. The NetWorker Administrator (and other local NetWorker users in the Administrators group) should now be able to modify NetWorker resources.


NWUI:
 
1. Click Browse External Roles.
2. If the NetWorker server is the default AUTHC server, use the Default option. If the NetWorker AUTHC host is on a different host, use the Remote Host option and specify the Host Name, Username, and Password. The default AUTHC port is 9090.
3. Click Browse.
4. Select the Administrators Group:
Adding the default Administrators group to the Application Administrators external roles field
5. Click Save on the Users and Groups window. The External Roles field should now list the NetWorker server's local Administrators group.
External Roles field showing local Administrators group 
6. Click Save on the Application Administrators window.
7. The NetWorker Administrator (and other local NetWorker users in the Administrators group) should now be able to modify NetWorker resources.

Affected Products

NetWorker

Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000037037
Article Type: Solution
Last Modified: 11 Nov 2025
Version:  10
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