NetWorker Administrator Account Unable to See/Manage Resources in NMC or NWUI
Summary: ALL resources (Clients, Groups, Policies, Devices, and so forth) appear to be missing in the NMC. The NMC's monitoring window is blank. nsradmin and nsrwatch confirm that the server resources still exist and the NetWorker server is still performing operations. ...
Symptoms
The Administrator account can see the NetWorker Server Resource (NSR) User Groups in the Server->User Groups tab:
Cause
The distinguished name (DN) of the local administrator's group was removed from the external roles field of the NetWorker server's "Application Administrators" user group.
[root@nsr ~]# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> show name; external roles
nsradmin> print type: nsr usergroup; name: application administrators
name: Application Administrators;
external roles: ;
nsradmin>
The user group Application Administrators should have a default external roles entry for the NetWorker server's Administrators group. For example: CN=Administrators,CN=Groups,CN=NETWORKER_SERVER_NAME,DC=DOMAIN_COMPONENT1,DC=DOMAIN_COMPONENT2
Resolution
First, confirm that the NetWorker server resources still exist.
nsradmin visual interface:
nsradmin
b) Enter:
visual
c) This opens a CLI visual interface, you can use ESC and TAB to navigate around the menu and select different resources.
Example:
C:\>nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> visual
Command: [Select] Next Prev Edit Create Delete Options Quit
Select a resource type to be displayed.
type: [NSR] NSR auditlog NSR client NSR client fix NSR ConnectEMC NSR Data Domain NSR device NSR directive
NSR label NSR license NSR lockbox NSR NAS discovery task NSR notification NSR policy NSR pool
NSR Protection Group NSR Protection Policy NSR Report Home NSR restricted data zone NSR schedule NSR service
NSR Snapshot Policy NSR stage NSR Storage Node NSR task NSR usergroup
2. Confirm that NetWorker server operations are visible using
nsrwatch (dependent on server's scheduled operations). Open an administrator command prompt or root shell on the NetWorker server, run: nsrwatch
If the above commands confirm that the NetWorker server is still operational, proceed with the steps outlined below.
Correct the Application Administrators External Roles Settings.
Linux: /opt/lgtonmc/etc/gstd.conf
Windows: <INSTALL_DRIVE>:\Program Files\EMC NetWorker\Management\GST\etc\gstd.conf
This file contains a string authsvc_hostname which is the AUTHC host used by the NMC.
Linux: /opt/nwui/logs/install.log
Windows: <INSTALL_DRIVE>:\Program Files\EMC NetWorker\nwui\logs\install.log
The install.log contains lines showing what host was set as the "Authentication server" during the NWUI initial configuration.
nsraddadmin -H AUTHC_SERVER_NAME -p 9090
[root@nsr ~]# nsraddadmin -H nsr.amer.lan -P 9090
134749:nsraddadmin: 'cn=Administrators,cn=Groups,dc=nsr,dc=amer,dc=lan' is already on the 'external roles' list of 'Security Administrators' user group.
134751:nsraddadmin: Added role 'cn=Administrators,cn=Groups,dc=nsr,dc=amer,dc=lan' to the 'Application Administrators' user group.
134749:nsraddadmin: 'cn=Users,cn=Groups,dc=nsr,dc=amer,dc=lan' is already on the 'external roles' list of 'Users' user group.
If the field was updated correctly, NMC resources and settings should now be visible.
Additional Information
As an alternative to the command-line method shown in the Resolution field, the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) can be used to correct the Application Administrators external roles.
3. Select the default Administrators group.
4. Click OK.
5. The NetWorker Administrator (and other local NetWorker users in the Administrators group) should now be able to modify NetWorker resources.
NWUI:
2. If the NetWorker server is the default AUTHC server, use the Default option. If the NetWorker AUTHC host is on a different host, use the Remote Host option and specify the Host Name, Username, and Password. The default AUTHC port is 9090.
3. Click Browse.
4. Select the Administrators Group:
7. The NetWorker Administrator (and other local NetWorker users in the Administrators group) should now be able to modify NetWorker resources.