Avamar:Hyper-Vバックアップが「HA VMを取得できませんでした」で失敗する

Summary: Avamar Windowsクラスター サービスがクラスター化された仮想マシンを取得できない場合、Avamarを使用したHyper-Vバックアップが失敗することがあります。この問題は、マルチプロキシ構成で、またはクラスター リソースが正しく構成されていない場合によく発生します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hyper-Vバックアップが次のようなエラーで失敗します。
Error <17211>: Failed to get the HA VMs from the Avamar Windows Cluster Service, Err = 80004005
Error <17203>: unable to prepare VMs for backup
Error <17179>: Failed to get the virtual machines from the Avamar Windows Cluster Service
その他のログ エントリーには、次のものがあります。
GetWmiConnection : Invalid parameter
Could not query clustered VMs. Failing multi proxy backup
Multi proxy backup did not complete successfully
データセットで指定された1つ以上のVMがクラスターから削除された可能性があります。

Cause

この問題には、いくつかの要因が考えられます。

  1. WMIまたはPowerShellサービス が障害発生状態または応答しない状態です。
  2. 権限の問題: Avamar Windowsクラスター サービスで使用されるアカウントには、Hyper-Vネームスペースへのアクセス権がありません。
  3. 不正なマルチプロキシ構成: 複数のノードがプライマリー プロキシとして設定されているか、セカンダリー ノードに --proxy フラグを avhypervvss.cmdの詳細を確認してください。
  4. データセットの構成ミス: データセットにリストされているVMは、クラスターに存在しなくなりました。

Resolution

  1. WMI接続を検証します
    PowerShellで次のコマンドを実行します。
    • Get-WmiObject -Query "Select * From mscluster_resource where Type='Virtual Machine'" -Namespace root\mscluster

コマンドが失敗した場合は、Hyper-Vノードを再起動してWMI機能をリストアします。

  1. 権限を確認します
    • ドメイン アカウント(Avamarプラグイン サービスで使用)を次の場所に追加します。
      • ローカル管理者
      • 各クラスター ノード上の WinRMRemoteWMIUsers グループ
    • アカウントがActive DirectoryのDomain Admins のメンバーであることを確認します。
    1. 正しいマルチプロキシ構成:
      • プライマリー ノードのみが必要です。
        • --multi-proxy=node1,node2,node3,node4
          --proxy
      • プロキシ設定を以下から削除します。 avhypervvss.cmd セカンダリー ノード上。
    2. データセットの更新:
      • クラスターに存在しなくなったVMをすべて削除します
      • フェールオーバー クラスター マネージャーでVMのステータスを確認します。

      Additional Information

      その他の情報

      • クラスター環境でのAvamar Hyper-Vバックアップに適用
      • これらの手順を実行しても問題が解決しない場合は、ログを収集してDellサポートにお問い合わせください

      Affected Products

      Avamar, Avamar Plug-in for Hyper-V VSS
      Article Properties
      Article Number: 000039412
      Article Type: Solution
      Last Modified: 05 Dec 2025
      Version:  5
      Find answers to your questions from other Dell users
      Support Services
      Check if your device is covered by Support Services.