Avamar: Hyper-V yedeklemeleri "HA VM'leri alınamadı" mesajıyla başarısız oluyor
Summary: Avamar Windows Cluster Service, kümelenmiş sanal makineleri alamadığında Avamar kullanan Hyper-V yedeklemeleri başarısız olabilir. Bu sorun genellikle çok proxy'li yapılandırmalarda veya küme kaynakları yanlış yapılandırıldığında oluşur. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Hyper-V yedeklemeleri aşağıdakine benzer hatalarla başarısız oluyor:
Error <17211>: Failed to get the HA VMs from the Avamar Windows Cluster Service, Err = 80004005
Error <17203>: unable to prepare VMs for backup
Error <17179>: Failed to get the virtual machines from the Avamar Windows Cluster Service
Ek günlük girişleri şunları içerebilir:
GetWmiConnection : Invalid parameter
Could not query clustered VMs. Failing multi proxy backup
Multi proxy backup did not complete successfully
Veri kümesinde belirtilen bir veya daha fazla VM kümeden kaldırılmış olabilir.
Cause
Bu soruna birkaç faktör katkıda bulunabilir:
- WMI veya PowerShell hizmetleri başarısız veya yanıt vermiyor durumunda.
- İzin sorunu: Avamar Windows Cluster Service tarafından kullanılan hesap, Hyper-V ad alanlarına erişime sahip değildir.
- Yanlış çoklu proxy yapılandırması: Birden çok düğüm birincil proxy olarak ayarlanmışsa veya ikincil düğümler
--proxyBayrakavhypervvss.cmd. - Veri kümesi yanlış yapılandırması: Veri kümesinde listelenen bir VM artık kümede mevcut değil.
Resolution
- WMI bağlantısını doğrulayın:
PowerShell'de şu komutu çalıştırın:-
Get-WmiObject -Query "Select * From mscluster_resource where Type='Virtual Machine'" -Namespace root\mscluster
-
Komut başarısız olursa, WMI işlevselliğini geri yüklemek için Hyper-V düğümünü yeniden başlatın.
- İzinleri doğrulayın:
- Aşağıdakilere etki alanı hesabını (Avamar Plug-in Service tarafından kullanılan) ekleyin:
- Yerel Yöneticiler
- Her küme düğümündeki WinRMReWMIUsers grupları
- Hesabın Active Directory'deki Domain Admins üyesi olduğunu doğrulayın.
- Aşağıdakilere etki alanı hesabını (Avamar Plug-in Service tarafından kullanılan) ekleyin:
- Doğru çoklu proxy yapılandırması:
- Yalnızca birincil düğümde şunlar bulunmalıdır:
-
--multi-proxy=node1,node2,node3,node4 --proxy
-
- 'ndan tüm proxy ayarlarını kaldırın
avhypervvss.cmdİkincil düğümlerde.
- Yalnızca birincil düğümde şunlar bulunmalıdır:
- Veri kümesini güncelleştirme:
- Kümede artık mevcut olmayan tüm VM'leri kaldırın
- Yük Devretme Kümesi Yöneticisi'nde VM durumunu doğrulayın.
Additional Information
Ek Bilgiler
- Kümelenmiş ortamlardaki Avamar Hyper-V yedeklemeleri için geçerlidir
- Bu adımlardan sonra sorun devam ederse günlükleri toplayın ve Dell Destek ekibiyle iletişime geçin
Affected Products
Avamar, Avamar Plug-in for Hyper-V VSSArticle Properties
Article Number: 000039412
Article Type: Solution
Last Modified: 05 Dec 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.