Avamar. Не удается зарегистрировать кластер Windows из-за сети резервного копирования

Summary: Регистрация клиента кластера с помощью инструмента Avamar Cluster Configuration может завершиться сбоем в средах, где имеется несколько сетевых карт и только резервная сеть может направлять трафик в сеть Avamar. В этой статье базы знаний представлены временные решения для решения этой проблемы. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При попытке зарегистрировать клиент кластера Windows с помощью инструмента конфигурации кластера Avamar в сети Avamar может появиться следующее сообщение об ошибке: 

"Error: Could not find cid.bin in var folder path (Example: O:\Avamar_logs\var\cid.bin). Please check avagent.log file to see if there are problems with client registration!  Tip: This error can occur if provided details for Avamar server are incorrect."

Следующие ошибки в avagent.log

avagent Error <5365>: Cannot connect to 10.x.xxx.xxx:28001.
avagent Error <6210>: Unable to register '/DELL\Cluster_client' with MCS at xxxxx.xxxx.lab.emc.com:28001
avagent Error <7500>: Registration error: NULL message received
Клиенты федеративного кластера (Exchange DAG, Hyper-V CSV) также могут не отображаться в консоли Avamar, даже если мастер кластеризации завершается успешно.

Cause

Клиенту кластера может не удаваться зарегистрироваться, если:

  • Узлы кластера имеют несколько сетевых карт.
  • Только сетевая плата, назначенная в качестве резервной сети , может направлять трафик в сеть Avamar.
  • По умолчанию агент кластера привязывается к производственному IP-адресу, для которого может отсутствовать шлюз по умолчанию или возможность подключения к сети Avamar.

Resolution

Настройте агент резервного копирования для <<службы имен>> кластеров для привязки к IP-адресу, который может обмениваться данными с сетью Avamar.

  1. Откройте инструмент управления отказоустойчивым кластером в ОС Windows.
  2. Перейдите к имени кластера —>Сервис и приложения. 
  3. Найдите службу агента резервного копирования для <<имени>> кластера, нажмите правой кнопкой мыши и выберите Свойства.
  4. Перейдите на вкладку Общие и скопируйте существующее содержимое поля Параметры запуска в Блокнот.
  5. Внесите следующие изменения в параметры запуска
    1. Edit --netbind=<<IP address of Backup network>>, that is --netbind=10.xx.xx.x
      Remove the --disablegui=true flag
  6. Сохраните изменения.
    1. Переведите ресурс агента резервного копирования в автономный режим.
    2. Переведите ресурс агента резервного копирования в оперативный режим.
Для клиентов кластера убедитесь, что сетевая плата, связанная с указанным IP-адресом, имеет шлюз по умолчанию или может подключаться к сети Avamar. Если нет, выберите другой доступный IP-адрес, который можно связать с существующим интерфейсом сетевой платы с доступом к сети Avamar.

Проверка возможности подключения:
Использование ping с исходным IP-адресом:

ping -S <source IP address> <Avamar grid IP>

Пример:

ping -S 10.x.x.x 192.xxx.x.x

Если вы видите следующее:

PING: transmit failed. General failure.

Выбранный IP-адрес не может получить доступ к сети. Измените конфигурацию сети или выберите другой IP-адрес.

Additional Information

  • Применяется к кластерам Windows и клиентам федеративных кластеров (Exchange DAG, Hyper-V CSV)
  • Если регистрация по-прежнему завершается ошибкой, просмотрите правила сетевой маршрутизации и межсетевого экрана
  • В сетях TCP/IP шлюз по умолчанию требуется для маршрутизации IP-пакетов в IP-подсеть, которая не входит в таблицу маршрутизации

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000039560
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.