Avamar: Avagent-logboeken tonen "CR_ERROR" tijdens het registreren of tijdens het maken van een back-up

Summary: Avagent-logboeken tonen fout "CR_ERROR"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenario 1 - Clientregistratie mislukt:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

--Of--

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

Scenario 2 - De registratie is voltooid, maar de back-ups blijven hangen in "Waiting client" of "Timed-Out End" zonder dataoverdracht:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

--Of--

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Cause

Als de avagent Logboekrapporten "No response to message" of "CR_ERROR Tijdens de eerste handdruk is er een communicatieprobleem dat de send/ack-berichten tussen het Avamar-raster en de client.

Opmerking: Alle fouten in beide scenario's duiden op netwerk- of firewallgerelateerde problemen in de omgeving van de klant.

Resolution

De volgende stappen kunnen worden gebruikt om te helpen bij het vinden van knelpunten:

1. Controleer of alle vereiste Avamar-poorten open zijn in de firewall en data kunnen verzenden en ontvangen.
(Avamar server naar client en client naar Avamar server)

2. Controleer of er antivirus- of malwaredetectiesoftware is die de data op Avamar-poorten blokkeert.

3. Als de client zich achter een NAT bevindt, controleer dan of routetabellen correct zijn ingesteld.

4. Als dezelfde fout op alle clients wordt weergegeven, moet u controleren of er geen wijzigingen zijn aangebracht in het Avamar-netwerk.

5. Schakel het netwerkteam in om het netwerkverkeer van de defecte client naar het Avamar-raster te traceren en te controleren op pakketdalingen in het netwerk.

6. Als er geen problemen kunnen worden gevonden, verzamel dan tcpdump als Wireshark of Netmon informatie en een Serviceaanvraag aanmaken.

Additional Information

Wireshark-bronnen:
 
TCPDump-bronnen:
  •    https://linuxtechlab.com/learn-use-tcpdump-command-examples(Externe link)

Affected Products

Avamar, Avamar Client
Article Properties
Article Number: 000040936
Article Type: Solution
Last Modified: 24 Sep 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.