ViPR SRM : Impossible d’accéder à la console front-end
Summary: Cet article fournit la résolution en cas d’impossibilité d’accéder à la console front-end.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Lorsque vous utilisez le navigateur Internet Explorer pour vous connecter, la console front-end ViPR SRM ne parvient pas à se charger et affiche l’erreur suivante :
This page can't be displayed
Lors de l’utilisation du navigateur Google Chrome pour se connecter, les utilisateurs recevaient l’erreur suivante :
This site can't be reached
Le journal Catalina de Tomcat contenait les erreurs suivantes :
SEVERE: Attempt to login to tomcat realm as 'ws-user' has failed from 'xx.xx.xx.xx'. Jan 31, 2019 7:44:08 AM com.sun.xml.ws.server.sei.EndpointMethodHandler invoke SEVERE: can't get valid user java.lang.SecurityException: can't get valid user at com.watch4net.apg.v2.remote.security.ApplicationUserMapperProvider.getUser(ApplicationUserMapperProvider.java:61) com.watch4net.apg.v2.remote.security.ApplicationUserMapperProvider.getUser(ApplicationUserMapperProvider.java:59) ... 53 more Caused by: com.watch4net.apg.gui.master.accessor.MasterDataAccessException: Unable to load user `ws-user` from master database! at com.watch4net.apg.gui.master.accessor.jdbc.JdbcMasterUserAccessor.load(JdbcMasterUserAccessor.java:396)
Cause
Tomcat n’a pas pu charger ou accéder à ws-user à partir de la base de données active.
Resolution
Dans un incident où cela s’est produit, le redémarrage de tous les services ViPR SRM sur le front-end a résolu le problème.
Instructions :
- PuTTY dans le front-end
- Accédez à /opt/APG/bin
- Exécutez les opérations suivantes.
./manage-modules.sh service stop all
- Exécutez la commande suivante :
./manage-modules.sh service start all
- Vérifiez que l’utilisateur peut se connecter à la console ViPR SRM avec succès.
Additional Information
Dans un scénario similaire où la console front-end ViPR SRM ne parvient pas à se charger, le journal Catalina peut contenir des erreurs légèrement différentes :
SEVERE: Error authentication user ws-user
com.watch4net.apg.gui.master.accessor.MasterDataAccessException: Unable to access users from master database!
at com.watch4net.apg.gui.master.accessor.jdbc.JdbcMasterUserAccessor.containsAlternate(JdbcMasterUserAccessor.java:305)....
Caused by: org.apache.commons.dbcp.SQLNestedException: Cannot get a connection, pool error Timeout waiting for idle object
at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:114)
Affected Products
SRMArticle Properties
Article Number: 000041107
Article Type: Solution
Last Modified: 01 Apr 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.