ViPR SRM:無法存取前端主控台

Summary: 本文提供無法存取前端主控台時的解決方案。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

使用 Internet Explorer 瀏覽器登入時,ViPR SRM 前端主控台無法載入,並顯示錯誤:

This page can't be displayed
無法顯示此頁面

使用 Google Chrome 瀏覽器登入時,使用者收到錯誤:

This site can't be reached
無法連線至此站點

Tomcat 的 Catalina 記錄有以下錯誤:

SEVERE: Attempt to login to tomcat realm as 'ws-user' has failed from 'xx.xx.xx.xx'.
Jan 31, 2019 7:44:08 AM com.sun.xml.ws.server.sei.EndpointMethodHandler invoke
SEVERE: can't get valid user
java.lang.SecurityException: can't get valid user
     at com.watch4net.apg.v2.remote.security.ApplicationUserMapperProvider.getUser(ApplicationUserMapperProvider.java:61)
 com.watch4net.apg.v2.remote.security.ApplicationUserMapperProvider.getUser(ApplicationUserMapperProvider.java:59)
     ... 53 more
Caused by: com.watch4net.apg.gui.master.accessor.MasterDataAccessException: Unable to load user `ws-user` from master database!
     at com.watch4net.apg.gui.master.accessor.jdbc.JdbcMasterUserAccessor.load(JdbcMasterUserAccessor.java:396)

 

Cause

Tomcat 無法從使用中的資料庫載入或存取 ws-user。

 

Resolution

在發生此情況的一個事件中,重新啟動前端的所有 ViPR SRM 服務解決了此問題。

指示:

  1. 膩子進入前端
  2. 前往 /opt/APG/bin
  3. 執行下列命令。
    ./manage-modules.sh service stop all
  4. 執行下列步驟:
    ./manage-modules.sh service start all
  5. 確認使用者可成功連線至 ViPR SRM 主控台。

 

Additional Information

在類似的情況下,如果 ViPR SRM 前端主控台無法載入,Catalina 記錄可能包含略有不同的錯誤:

SEVERE: Error authentication user ws-user
com.watch4net.apg.gui.master.accessor.MasterDataAccessException: Unable to access users from master database!
    at com.watch4net.apg.gui.master.accessor.jdbc.JdbcMasterUserAccessor.containsAlternate(JdbcMasterUserAccessor.java:305)....


Caused by: org.apache.commons.dbcp.SQLNestedException: Cannot get a connection, pool error Timeout waiting for idle object
    at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:114)

 

Affected Products

SRM
Article Properties
Article Number: 000041107
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.