ECS: NFS-skriving gir en I/O-feil etter en viss mengde data

Summary: NFS-skrivinger mislykkes med en I/O-feil på grunn av manglende synkroniseringssamsvar.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Det er en ny filsystemaktivert bøtte.

NFS-skrivinger mislykkes med en I/O-feil på grunn av manglende synkroniseringssamsvar.

NFS-klienteksempel på problemet:
root@client~:/mnt_ecs# dd if=/dev/zero of=/mnt_ecs/test bs=1024 count=80000
dd: write error: I/O error
dd: write error: I/O error
root@client:/mnt_ecs# ll
total 8222
drwx---rwx- 3 2147483647 2147483647 96 Aug 13 10:51 .
drwxr-xr-x- 30 root system 4096 Aug 07 10:46 ..
-rw-r--r--- 1 root system 2102272 Aug 13 10:51 test
I henhold til loggplasseringen nedenfor: (En forventet forespørsel ble ikke sett på dataheadsvc tjeneste)
Kommando:
# cat /opt/emc/caspian/fabric/agent/services/object/main/log/dataheadsvc.log
Eksempel:
admin@node1~>cat /opt/emc/caspian/fabric/agent/services/object/main/log/dataheadsvc.log
2018-08-17T06:09:02,499 [RpcDispatcherWriteIO-5411370]  INFO  RpcProgramNfs3.java (line 241) No sync response, expect an async response for request  WriteRequest : FileHandle:[objectId = e7e6d9327488f5a316420e1f8805fac18d8a4f0773173ff12de2512a384d25de, ownerZoneUUID = 4f7a7b18-4e08-4e25-9bbb-ebeb02b085c3]Export:2 offset:0 count:524288 stablehowUNSTABLE
2018-08-17T06:09:03,261 [RpcDispatcherMD-5323256] ERROR  RpcProgramNfs3.java (line 277) Error processing NfsRequest: xid:1229074411 ip:/<Client IP> SysSecurity:  AuthStatus:AUTH_OK Uid:0 Gid:0 Proc:SETATTR SetAttrRequest : FileHandle:[objectId = e7e6d9327488f5a316420e1f8805fac18d8a4f0773173ff12de2512a384d25de, ownerZoneUUID = 4f7a7b18-4e08-4e25-9bbb-ebeb02b085c3]Export:2 SetAttr3Object : uid:0 gid:0 mode:0 atime:null mtime:null verf:10487808 updateFields:[SIZE] check:true ctime(NfsTime-1534486142s, 467000000ns) NfsResponse:  SetAttr3Response : status:NFS3ERR_NOT_SYNC wccData: WccData: WccAttr: size:10485760 mtime:(NfsTime-1534486142s, 600000000ns) ctime:(NfsTime-1534486143s, 243000000ns) postOpAttr type:NFSREG mode:rw-r--r-- nlink:1 uid:0 gid:0 size:10485760 used:10485760 rdev:(Specdata3: specdata10, specdata2:0) fileid:1019241384186633961 atime:(NfsTime-1534486143s, 243000000ns) mtime:(NfsTime-1534486142s, 600000000ns) ctime:(NfsTime-1534486143s, 243000000ns) RpcError: null

Cause

Det er manglende samsvar mellom synkronisering mellom klient og server.
  1. Enten monterte klienten den filsystemaktiverte bøtten med synkroniseringsalternativet.
 Kommando: (Ingen utdata forventet)
# mount -V nfs -o vers=3,proto=tcp,port=2049,sync <ECS IP> :/ns_nfs/nfs /mnt_ecs
  1. Alternativet Eksporter vert i ECS-grensesnittfilmenyen er endret til Synkroniser (standard er Asynkron)
Alternativet Eksporter vert i ECS-grensesnittfilmenyen er endret til Synkroniser (standard er Asynkron)

Resolution

Kjør følgende kontroller:

  • Kontroller om klienten spesifiserer alternativet Sync Mount , og fjern det i så fall.
  • Kontroller retningslinjen for skriveoverføring i alternativene for eksport av vert (Fileksport >), og endre den til Asynkron.
NFS v3 gir mulighet for sikre asynkrone skriveoperasjoner som øker ytelsen i forhold til synkrone skriveoperasjoner som ofte var et problem i tidligere NFS-implementeringer.
 
Merk: Øke wsize i monteringsalternativet gjør det mulig å overføre mer data før I/O-feilen vises.

Fra RFC 1813 NFS versjon 3-protokollenDenne hyperkoblingen tar deg til et nettsted utenfor Dell Technologies.:
NFS3ERR_NOT_SYNC:
Update synchronization mismatch was detected during a SETATTR operation.

Additional Information

Affected Products

Elastic Cloud Storage

Products

ECS Appliance, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage
Article Properties
Article Number: 000042461
Article Type: Solution
Last Modified: 03 Sep 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.