Data Domain: detectar direcciones IP duplicadas

Summary: En este documento, se demuestran tres métodos para verificar que no existan problemas de IP duplicados.

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Symptoms



 

Detección de direcciones IP duplicadas

PROPÓSITO

En este documento, se describen cuatro métodos para detectar direcciones IP duplicadas en una red.

  1. Función de detección automática de IP duplicada, disponible en DD OS 5.3
  2. Comando de la CLI a nivel de usuario "net troubleshooting duplicate-ip", disponible en DD OS 5.1
  3. Utilice herramientas basadas en la línea de comandos que comparen la dirección IP y MAC correspondiente
  4. Usar ping para verificar un problema de IP duplicada

APLICAR A

  • Todos los sistemas Data Domain
  • Todas las versiones de software

Cause

CAUSA

Las direcciones IP duplicadas provocan que se pierdan las conexiones.  En un volcado de TCP, hay muchos paquetes RESET debido a direcciones IP duplicadas.

Resolution

     

    SOLUCIÓN

    Método 1:

    DD OS 5.3 presenta una nueva función para detectar automáticamente direcciones IP duplicadas y enviar una alerta.  La función se ejecuta en modo pasivo (predeterminado) o en modo activo. 

    1. Para habilitar la función en modo activo, configure la clave de registro de DD OS de la siguiente manera.
    Para activar el uso:

    regset  config.net.dad_active_mode 1
    

    Para desactivar el uso:

    regset  config.net.dad_active_mode 0
    

    Cuando se ejecuta en modo activo, la configuración de una interfaz de red con una dirección IP puede tardar hasta 90 segundos mientras el sistema comprueba si hay duplicación de direcciones IP.   A continuación, se muestra un ejemplo de resultado:

    # net config eth0b 10.32.228.83 **** Found duplicate address: ifname=eth0b, ip=10.32.228.83, remote mac=60:EB:69:DC:28:AE; local interface eth0b has been brought down.

    2. Para habilitar la función en modo pasivo, se puede utilizar la opción net.

    • Active la comprobación pasiva y envíe una alerta en caso de error: 
      net option set net.dd.dad_alert 1
    • Active la comprobación pasiva, pero solo registre errores, sin alerta:  
      net option set net.dd.dad_alert 2
    • Desactive la verificación pasiva:
      net option set net.dd.dad_alert 0

    El modo pasivo comprueba la actividad del protocolo de resolución de direcciones (ARP) en el kernel.  Si se encuentra una dirección IP duplicada, el sistema envía una alerta o registra un error en función de la configuración de la función.  A continuación, se muestra un ejemplo de salida:

    # ping -c 1 -I eth0a 10.32.228.83
    # alerts show current
    
    29 Tue Feb 28 10:55:26 2012 ERROR Network DuplicatedIPAddr=10.32.228.83 Duplicate IP address detected.

    Método 2:

    Utilice el comando net troubleshooting duplicate-ip.  Este comando envía un protocolo de resolución de direcciones (ARP) desde cada dirección IP en el sistema Data Domain y espera una respuesta.  Este método se aplica a un sistema con DD OS 5.1 o superior.

    1. # net troubleshooting duplicate-ip

       
    2. Si no se encuentra ninguna IP duplicada, el resultado es:
    No duplicate IP addresses detected
    
    1. Si se encuentra una IP duplicada, se muestra un ejemplo del resultado como el siguiente:
    Port      IP Address   Details
    -------   ----------   -----------------------------------------------
    eth0:55   10.10.10.1   Duplicate IP from MAC address 00:A0:D1:EC:FE:AD
    -------   ----------   -----------------------------------------------
     
    Método 3:

    Verifique la dirección MAC de la interfaz Ethernet en el sistema Data Domain mediante el protocolo de resolución de direcciones (ARP).

     

    NOTA: Este método solo se puede realizar desde un sistema que esté en la misma subred que el sistema Data Domain.

     

    1. Conéctese e inicie sesión en el sistema Data Domain.
    2. Determine la dirección IP configurada. En el símbolo del sistema, escriba:
    # net show settings
    
    Anote la dirección IP.

    Resultado de muestra:

    port  enabled  DHCP  IP address        netmask           type     additional setting
    ----  -------  ----  ----------------  ----------------  -------  ------------------
    eth0  yes      yes   192.168.9.65*     255.255.252.0     *        n/a
    ----  -------  ----  ----------------  ----------------  -------  -----------------
    
    
     
    1. Determine la dirección MAC. En el símbolo del sistema, escriba:
    # net show hardware
    
    
     

    Resultado de muestra:

    Port  Speed     Duplex   Supp Speeds  Hardware Address   Physical  Link Status
    ----  --------  -------  -----------  -----------------  --------  -----------
    eth0  1000Mb/s  full     10/100/1000  00:15:17:8f:59:64  Copper    yes
    ----  --------  -------  -----------  -----------------  --------  -----------
    Tenga en cuenta la dirección MAC asociada con la dirección IP asignada a la interfaz Ethernet pertinente.

    (En este ejemplo, la interfaz Ethernet eth0 tiene la dirección IP 192.168.9.65 y la dirección MAC 00:15:17:8f:59:64).

    Utilice el protocolo de resolución de direcciones (ARP) de Windows para determinar si hay una dirección IP duplicada en la red.

    1. Inicie sesión en el servidor de medios de Windows que está conectado al sistema Data Domain.
    2. Haga clic en Start-Run> y escriba:

    cmd

    Clic: OK

    1. En el símbolo del sistema, escriba:  
    ARP -a 192.168.9.65

     

    1. Ejecute este comando continuamente durante al menos 20 segundos y cada vez la salida debe contener la dirección MAC 00:15:17:8f:59:64
    2. Si el resultado tiene cualquier otra dirección MAC, existe una IP duplicada en la red.

    Método 4:

    Uso de ping para verificar un problema de IP duplicada:

    Este método es más disruptivo, ya que requiere desconectar el cable Ethernet, seguido de una simple prueba de ping.

     

    NOTA: Asegúrese de que no se realicen respaldos en el sistema y de que el sistema sea local en su ubicación.

     

    1. Desconecte el cable de Ethernet del sistema Data Domain.
    2. Inicie sesión en el servidor de medios de Windows que está conectado al sistema Data Domain.
    3. Haga clic en Start-Run> y escriba:

    cmd

    Clic: OK

    1. En el símbolo del sistema, escriba:
    #ping <ip address of the Data Domain system>

     

    Ejemplo:

    ping 192.168.9.65

     

    1. No debería haber una respuesta de ping ya que el cable está desconectado. Si hay una respuesta de ping, esto confirmaría que la dirección IP ya está siendo utilizada por otro sistema. La solución es utilizar una dirección IP diferente o ponerse en contacto con el administrador de red.
    2. Vuelva a conectar el cable Ethernet al sistema Data Domain.

    Affected Products

    Data Domain, DD OS 5.1, DD OS 5.3
    Article Properties
    Article Number: 000042611
    Article Type: Solution
    Last Modified: 03 Jul 2024
    Version:  5
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