Data domain — wykrywanie zduplikowanych adresów IP

Summary: W tym dokumencie przedstawiono trzy metody sprawdzania, czy nie występują problemy ze zduplikowanym adresem IP.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



 

Wykrywanie zduplikowanych adresów IP

ZASTOSOWANIE

W tym dokumencie opisano cztery metody wykrywania zduplikowanych adresów IP w sieci.

  1. Funkcja automatycznego wykrywania zduplikowanego adresu IP, dostępna w DD OS 5.3
  2. Polecenie CLI "net troubleshooting duplicate-ip" na poziomie użytkownika, dostępne w systemie DD OS 5.1
  3. Korzystanie z narzędzi opartych na wierszu poleceń porównujących adres IP i odpowiadający mu adres MAC
  4. Użyj polecenia ping, aby zweryfikować problem ze zduplikowanym adresem IP

ZASTOSUJ DO

  • Wszystkie systemy Data Domain
  • Wszystkie wersje oprogramowania

Cause

PRZYCZYNA

Zduplikowane adresy IP powodują zrywanie połączeń.  W zrzucie TCP znajduje się wiele pakietów RESET z powodu zduplikowanych adresów IP.

Resolution

     

    ROZWIĄZANIE

    Metoda 1:

    DD OS 5.3 wprowadza nową funkcję automatycznego wykrywania zduplikowanych adresów IP i wysyłania alertów.  Funkcja działa w trybie pasywnym (domyślnym) lub aktywnym. 

    1. Aby włączyć funkcję w trybie aktywnym, ustaw klucz rejestru systemu operacyjnego DD w następujący sposób.
    Aby włączyć korzystanie:

    regset  config.net.dad_active_mode 1
    

    Aby wyłączyć użycie:

    regset  config.net.dad_active_mode 0
    

    Podczas pracy w trybie aktywnym konfigurowanie interfejsu sieciowego z adresem IP może potrwać do 90 s, podczas gdy system sprawdza duplikację adresów IP.   Przykładowe dane wyjściowe podano poniżej:

    # net config eth0b 10.32.228.83 **** Found duplicate address: ifname=eth0b, ip=10.32.228.83, remote mac=60:EB:69:DC:28:AE; local interface eth0b has been brought down.

    2. Aby włączyć funkcję w trybie pasywnym, można użyć opcji sieciowej.

    • Włącz pasywne sprawdzanie i wysyłaj alert w przypadku błędu: 
      net option set net.dd.dad_alert 1
    • Włącz pasywne sprawdzanie, ale rejestruj tylko błędy bez alertu:  
      net option set net.dd.dad_alert 2
    • Wyłącz pasywne zaznaczanie:
      net option set net.dd.dad_alert 0

    Tryb pasywny sprawdza aktywność protokołu ARP (Address Resolution Protocol) w jądrze.  W przypadku znalezienia zduplikowanego adresu IP system wysyła alert i/lub rejestruje błąd w oparciu o konfigurację funkcji.  Przykład wyjściowy podano poniżej:

    # ping -c 1 -I eth0a 10.32.228.83
    # alerts show current
    
    29 Tue Feb 28 10:55:26 2012 ERROR Network DuplicatedIPAddr=10.32.228.83 Duplicate IP address detected.

    Metoda 2:

    Użyj polecenia net troubleshooting duplicate-ip.  To polecenie wysyła protokół ARP (Address Resolution Protocol) z każdego adresu IP w systemie Data Domain i czeka na odpowiedź.  Ta metoda dotyczy systemu z DD OS w wersji 5.1 lub nowszej.

    1. # net troubleshooting duplicate-ip

       
    2. Jeśli nie zostanie znaleziony zduplikowany adres IP, dane wyjściowe są następujące:
    No duplicate IP addresses detected
    
    1. Jeśli zostanie znaleziony zduplikowany adres IP, przykład danych wyjściowych jest podobny do poniższego:
    Port      IP Address   Details
    -------   ----------   -----------------------------------------------
    eth0:55   10.10.10.1   Duplicate IP from MAC address 00:A0:D1:EC:FE:AD
    -------   ----------   -----------------------------------------------
     
    Metoda 3:

    Sprawdź adres MAC interfejsu Ethernet w systemie Data Domain przy użyciu protokołu ARP (Address Resolution Protocol).

     

    UWAGA: Tę metodę można wykonać tylko z systemu, który znajduje się w tej samej podsieci, co system Data Domain.

     

    1. Połącz się i zaloguj do systemu Data Domain.
    2. Określ skonfigurowany adres IP. W wierszu polecenia wpisz:
    # net show settings
    
    Zanotuj adres IP.

    Przykładowe dane wyjściowe:

    port  enabled  DHCP  IP address        netmask           type     additional setting
    ----  -------  ----  ----------------  ----------------  -------  ------------------
    eth0  yes      yes   192.168.9.65*     255.255.252.0     *        n/a
    ----  -------  ----  ----------------  ----------------  -------  -----------------
    
    
     
    1. Określ adres MAC. W wierszu polecenia wpisz:
    # net show hardware
    
    
     

    Przykładowe dane wyjściowe:

    Port  Speed     Duplex   Supp Speeds  Hardware Address   Physical  Link Status
    ----  --------  -------  -----------  -----------------  --------  -----------
    eth0  1000Mb/s  full     10/100/1000  00:15:17:8f:59:64  Copper    yes
    ----  --------  -------  -----------  -----------------  --------  -----------
    Zanotuj adres MAC powiązany z adresem IP przypisanym do odpowiedniego interfejsu Ethernet.

    (W tym przykładzie interfejs Ethernet eth0 ma adres IP 192.168.9.65 i adres MAC 00:15:17:8f:59:64).

    Użyj protokołu ARP (Address Resolution Protocol) systemu Windows, aby określić, czy w sieci istnieje zduplikowany adres IP.

    1. Zaloguj się na serwerze mediów Windows połączonym z systemem Data Domain.
    2. Kliknij Start-Uruchom> i wpisz:

    cmd

    Klikać: OK

    1. W wierszu polecenia wpisz:  
    ARP -a 192.168.9.65

     

    1. Uruchom to polecenie nieprzerwanie przez co najmniej 20 sekund i za każdym razem dane wyjściowe powinny zawierać adres MAC 00:15:17:8f:59:64
    2. Jeśli wyjście ma inny adres MAC, w sieci istnieje zduplikowany adres IP.

    Metoda 4:

    Używanie pingu do weryfikacji problemu ze zduplikowanym adresem IP:

    Ta metoda jest bardziej uciążliwa, ponieważ wymaga odłączenia Ethernet, a następnie wykonania prostego testu ping.

     

    UWAGA: Upewnij się, że w systemie nie są tworzone żadne kopie zapasowe i że system jest lokalny dla Twojej lokalizacji!

     

    1. Odłącz Ethernet od systemu Data Domain.
    2. Zaloguj się do serwera multimediów Windows połączonego z systemem Data Domain.
    3. Kliknij Start-Uruchom> i wpisz:

    cmd

    Klikać: OK

    1. W wierszu polecenia wpisz:
    #ping <ip address of the Data Domain system>

     

    Example:

    ping 192.168.9.65

     

    1. Nie powinno być odpowiedzi ping, gdy jest odłączony. Jeśli pojawi się odpowiedź ping, potwierdzi to, że adres IP jest już używany przez inny system. Rozwiązaniem jest użycie innego adresu IP lub skontaktowanie się z administratorem sieci.
    2. Podłącz ponownie Ethernet do systemu Data Domain.

    Affected Products

    Data Domain, DD OS 5.1, DD OS 5.3
    Article Properties
    Article Number: 000042611
    Article Type: Solution
    Last Modified: 03 Jul 2024
    Version:  5
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.