Data Domain - espaço baixo em /ddvar
Summary: Este artigo lista etapas sobre como liberar espaço em disco do diretório /ddvar. O diretório ddvar/ é um diretório administrativo onde são colocados os arquivos de log, os pacotes gerados de carregamento de suporte, os arquivos core compactados e os pacotes de upgrade .rpm. Ocasionalmente, esse diretório pode ficar muito cheio, acionando o sistema Data Domain para enviar um alerta: ...
Symptoms
O diretório /ddvar (/ddvar/ e /ddr/var/ podem ser usados de modo intercambiável) é um diretório administrativo onde são colocados os arquivos de log, os pacotes gerados de carregamento de suporte, os arquivos core compactados e os pacotes de upgrade .rpm. Ocasionalmente, esse diretório pode ficar muito cheio, acionando o sistema Data Domain para enviar um alerta:
# alerts show current
Id Post Time Severity Class Object Message
----- ------------------------ -------- ----------------- ------ --------------------------------------------------------------------------
p0-36 Tue Sep 17 17:39:12 2024 ERROR SystemMaintenance Espaço baixo em /ddvar para atividades de manutenção do sistema.
----- ------------------------ -------- ----------------- ------ --------------------------------------------------------------------------
A entrada de registro correspondente tem a seguinte aparência:
dynamic.ems.708.1.401.1243325160.1.5 = falta de espaço em /ddvar para atividades de manutenção do sistema.
Alguns processos, inclusive o FS (que lida com todo o acesso aos dados), dependem da partição /ddvar para gravar logs e, se a partição ficar completamente cheia e não for possível gravar nela, o processo do FS poderá eventualmente não funcionar corretamente, morrer e não inicializar mais como resultado. Por isso, é muito importante que os clientes prestem atenção nesses alertas e ajam adequadamente.
Cause
O excesso de arquivos de log armazenados na partição do sistema operacional está fazendo com que o ddvar fique sem espaço, às vezes, quando os arquivos principais são armazenados em /ddr/var/ (e não em partições separadas, como /ddr/var/core/ ou /ddr/var/ext/), essa também pode ser a causa. Às vezes, os SUBs são muito grandes (vários GiB) e o cliente continua criando mais para solução de problemas, de modo que o espaço em disco está sendo consumido rapidamente. Às vezes, há um problema em que o rodízio de grandes arquivos de log falha ou em que as sobras de esforços anteriores de solução de problemas ocupam espaço em disco desnecessário em /ddr/var/.
Resolution
Espaço baixo em /ddvar
OBJETIVO
Este artigo lista as etapas sobre como liberar espaço em disco do /ddvar diretório.O DDVAR/ Diretório é um diretório administrativo onde os arquivos de log, os pacotes de upload de suporte gerados, os arquivos principais compactados e .rpm Os pacotes de upgrade são colocados. Ocasionalmente, esse diretório pode ficar muito cheio, acionando o sistema Data Domain para enviar um alerta:
# alerts show current Id Post Time Severity Class Object Message ----- ------------------------ -------- ----------------- ------ -------------------------------------------------------------------------- p0-36 Tue Sep 17 17:39:12 2024 ERROR SystemMaintenance Space running low in /ddvar for system maintenance activities. ----- ------------------------ -------- ----------------- ------ --------------------------------------------------------------------------A entrada de registro correspondente tem a seguinte aparência:
dynamic.ems.708.1.401.1243325160.1.5 = Space running low in /ddvar for system maintenance activities.
SINTOMAS
- Alerta "Espaço baixo em /ddvar para atividades de manutenção do sistema".
- Alerta: "O espaço está acabando em /ddvar. Limpe o espaço ou o recurso de despejo do núcleo será desativado."
- Alerta: "O recurso de core dump agora está desativado devido à falta de espaço em /ddvar"
APLICA-SE A
- Todos os sistemas Data Domain
- Todas as versões de software
SOLUÇÃO
========== ========== DE USO DO SERVIDOR Tamanho do recurso GiB usado GiB Aproveitar GiB Use% ------------------ -------- -------- --------- ---- /backup: pré-compactação - 17814.5 - - /backup: pós-compactação 1892,9 1099,1 793,8 58% /ddvar 19,7 14,1 4,6 75%
- Confirm /ddvar O espaço está acabando.
No prompt do sistema Data Domain, digite 180649 :Df - Observe que o espaço usado em /ddvar pode aumentar temporariamente e causar alertas transitórios de uso de espaço, conforme descrito em Aumentos transitórios deuso de espaço /ddvar181878 KB. Se você ainda precisar limpar arquivos em /ddvar para liberar espaço adicional, continue com as próximas etapas.
- Determine o nome de host e o endereço IP do sistema Data Domain.
hostname The Hostname is: support1.emc.local net lookup support1.emc.local has address 192.168.1.52
Liberando espaço em disco na pasta \ddvar usando a linha de comando do Datadomain [ao conectar via ssh] e o Console da Web [GUI].
1. Acesse o Datadomain usando um client SSH, como putty
2. Liste os arquivos core armazenados no sistema (observe que esses comandos não estão disponíveis em todas as versões do DDOS):
# support coredump list to delete specific core file use: # support coredump delete [corefile.filename] to delete all of them use: # support coredump delete all
3. Listar os pacotes de suporte armazenados no sistema
# support bundle list to delete specific support bundle # support bundle delete <bundle-name-list> to delete all support bundles # support bundle delete all
4. Conecte-se à interface
do console da Web do Data Domain System Manager 5. Navegue até Sistema de manutenção >
6. Na tabela "Pacotes de upgrade disponíveis no sistema Data Domain", selecione o pacote de upgrade que você pode encontrar marcando a caixa ao lado do nome do arquivo
do pacote 7. Clique no botão "Remove Upgrade Package" Liberando espaço em disco na pasta \ddvar usando um sistema baseado no Microsoft Windows.
- Certifique-se de que a lista de acesso (ACL) do sistema Data Domain esteja configurada 181315 para permitir o acesso do sistema atual.
- Exclua arquivos core antigos do sistema Data Domain. Nota: Se o nome do host não funcionar, tente usar o endereço IP .
========== ========== DE USO DO SERVIDOR Tamanho do recurso GiB usado GiB Aproveitar GiB Use% ------------------ -------- -------- --------- ---- /backup: pré-compactação - 17814.5 - - /backup: pós-compactação 1892,9 1099,1 793,8 58% /ddvar 19,7 3,2 16,5 12%
- No sistema Windows, clique na iniciar e escolha Executar... e digite o endereço IP (ou nome do host) e o caminho do compartilhamento \ddvar.
Clique em OK
- Autentique-se no DataDomain Restorer com uma das seguintes contas para ter permissões completas para o compartilhamento /ddvar:
- Conta sysadmin padrão do restaurador
- Outra conta local do restaurador que faz parte do Class admin
Confirme com o comando # user show list - Conta de administrador do Active Directory que mostra o ID do grupo como 50
Confirme com o comando # cifs troubleshooting user 10500
- Exclua os arquivos principais, se houver. Abra o \núcleo pasta.
- Se houver arquivos principais presentes, liste-os por data (visualização detalhada). Se houver arquivos principais datados nas últimas 24 horas, isso pode indicar um problema mais sério que precisará ser analisado mais a fundo. Se esse for o caso, entre em contato com o provedor de suporte contratado, carregue um 180563 de erro de link do pacote de suporte (SUB) e o arquivo principal mais recente depois de criar um Crie um chamado
- Se os arquivos principais não estiverem atualizados, realce e exclua todos os arquivos.
- Exclua arquivos antigos do Support Upload Bundle (SUB). Navegue até a \ddvar\support pasta.
- Realce e exclua todos os arquivos do pacote de suporte (support-bundle.tar.gz*)
- Excluir arquivos de upgrade antigos (.rpm files) do sistema Data Domain.
Navegue até a \ddvar\releases pasta. Realce e exclua todos os arquivos.
Nota: .rpm Os arquivos são usados temporariamente (apenas durante os upgrades). Após o upgrade do sistema, esses arquivos não serão mais necessários. - Verifique se o espaço foi recuperado.
No prompt do sistema Data Domain, digite:Df
========== ========== DE USO DO SERVIDOR Tamanho do recurso GiB usado GiB Aproveitar GiB Use% ------------------ -------- -------- --------- ---- /backup: pré-compactação - 17814.5 - - /backup: pós-compactação 1892,9 1099,1 793,8 58% /ddvar 19,7 3,2 16,5 12%
- Certifique-se de que a ACL (Access List, lista de acesso) NFS do sistema Data Domain esteja configurada 181315 para permitir o acesso do sistema atual.
- Monte a exportação /ddvar no sistema client. 181310
- Exclua os arquivos core antigos (se houver) do sistema Data Domain.
No prompt de comando do sistema client NFS, digite:ls -l /ddvar/core- Se houver arquivos principais datados nas últimas 24 horas, isso pode indicar um problema mais sério que precisará ser analisado mais a fundo. Se esse for o caso, entre em contato com o provedor de suporte contratado, carregue um 180563 de erro de link do pacote de suporte (SUB) e o arquivo principal mais recente depois de criar um Crie um chamado
- Se os arquivos principais não estiverem atualizados, exclua todos os arquivos.
RM/ddvar/core/*
- Exclua arquivos antigos do Support Upload Bundle (SUB). No prompt de comando do sistema client NFS, digite:
RM /ddvar/support/support-bundle.*
- Excluir arquivos de upgrade antigos (.rpm arquivos)
No prompt de comando do sistema client NFS, digite:RM/ddvar/releases/*.rpm - Verifique se o espaço foi recuperado.
No prompt do sistema Data Domain, digite:Df
- No sistema Windows, clique na iniciar e escolha Executar... e digite o endereço IP (ou nome do host) e o caminho do compartilhamento \ddvar.
REFERÊNCIA
Nota: Os links deste artigo são apenas para clientes registrados da Dell.