Data Domain – ont om utrymme i /ddvar

Summary: Den här artikeln innehåller steg för hur du frigör diskutrymme från katalogen /ddvar. Katalogen ddvar/ är en administrativ katalog där loggfiler, genererade supportuppladdningspaket, komprimerade kärnfiler och .rpm-uppgraderingspaket placeras. Ibland kan katalogen bli för full vilket utlöser att Data Domain-systemet skickar en varning: ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Katalogen /ddvar (/ddvar/ och /ddr/var/ kan användas omväxlande) är en administrativ katalog där loggfiler, genererade supportuppladdningspaket, komprimerade kärnfiler och .rpm-uppgraderingspaket placeras. Ibland kan katalogen bli för full vilket utlöser att Data Domain-systemet skickar en varning:

# alerts show current
Id Post Time Severity Class Object Message
----- ------------------------ -------- ----------------- ------ --------------------------------------------------------------------------
p0-36 Tue Sep 17 17:39:12 2024 ERROR SystemMaintenance Utrymmet börjar ta slut i /ddvar för systemunderhållsaktiviteter.
-----   ------------------------   --------   -----------------   ------   --------------------------------------------------------------------------

Motsvarande registerpost ser ut så här:

dynamic.ems.708.1.401.1243325160.1.5 = Ont om utrymme i /ddvar för systemunderhållsaktiviteter.

Vissa processer, inklusive FS (som hanterar all dataåtkomst) förlitar sig på /ddvar-partitionen för att skriva loggar, och om partitionen blir helt full och inte kan skrivas till kan FS-processen så småningom misslyckas att fungera korrekt och kan dö och inte starta längre som ett resultat. Därför är det mycket viktigt att kunderna uppmärksammar dessa varningar och agerar därefter.

Cause

För många loggfiler som lagras i operativsystempartitionen gör att ddvar får slut på utrymme, ibland när kärnfiler lagras i /ddr/var/ (och inte i separata partitioner som /ddr/var/core/ eller /ddr/var/ext/), kan detta också vara orsaken. Ibland är SUB:er mycket stora (flera GiB) och kunden fortsätter att skapa fler för felsökning, så diskutrymmet förbrukas snabbt. Ibland finns det ett problem med stora loggfiler som inte kan roteras, eller rester från tidigare felsökningsinsatser, som tar upp onödigt diskutrymme under /ddr/var/.

Resolution

Ont om utrymme i /ddvar

SYFTE

I den här artikeln beskrivs hur du frigör diskutrymme från /ddvar katalog.
Den ddvar/ katalog är en administrativ katalog där loggfiler, genererade supportuppladdningspaket, komprimerade kärnfiler och .rpm uppgraderingspaket placeras. Ibland kan katalogen bli för full vilket utlöser att Data Domain-systemet skickar en varning:
# alerts show current
Id      Post Time                  Severity   Class               Object   Message
-----   ------------------------   --------   -----------------   ------   --------------------------------------------------------------------------
p0-36   Tue Sep 17 17:39:12 2024   ERROR      SystemMaintenance            Space running low in /ddvar for system maintenance activities.
-----   ------------------------   --------   -----------------   ------   --------------------------------------------------------------------------
Motsvarande registerpost ser ut så här:
dynamic.ems.708.1.401.1243325160.1.5 = Space running low in /ddvar for system maintenance activities.

 

SYMTOM

  • Varning "Utrymmet börjar ta slut /ddvar för systemunderhållsaktiviteter."
  • Varning! "Utrymmet börjar ta slut i /ddvar. Rensa utrymme eller kärndumpfunktionen kommer att inaktiveras."
  • Varning! "Kärndumpfunktionen är nu inaktiverad på grund av utrymmesbrist i /ddvar"

GÄLLER

  • Alla Data Domain-system
  • Alla programvaruversioner

LÖSNING

========== SERVERANVÄNDNING ==========
Resursstorlek GiB Använda GiB Avail GiB Use%
------------------         --------        --------           ---------      ----
/backup: före komp - 17814.5 - -
/backup: efter komp 1892,9 1099,1 793,8 58 %
/ddvar 19,7 14,1 4,6       75 %

  1. Bekräfta /ddvar börjar få ont om utrymme.
    Vid systemkommandotolken Data Domain skriver 180649 :
    df
  2. Observera att utrymmet som används i /ddvar kan öka tillfälligt och orsaka tillfälliga utrymmesanvändningsvarningar enligt beskrivningen iTillfälliga /ddvar-utrymmesanvändningen ökar181878 kB. Om du fortfarande behöver rensa filer i /ddvar för att frigöra ytterligare utrymme fortsätter du med nästa steg.
  3. Fastställ värdnamn och IP-adress för Data Domain-systemet .
    hostname
    The Hostname is: support1.emc.local
    
    	
    net lookup
    support1.emc.local has address 192.168.1.52
    	

Frigör diskutrymme i mappen \ddvar med hjälp av Datadomain-kommandoraden [vid anslutning via ssh] och webbkonsolen [GUI].
1. Få åtkomst till Datadomain med en SSH-klient som PuTTY
2. Visa en lista över kärnfilerna som lagras i systemet (observera att dessa kommandon inte är tillgängliga på alla DDOS-versioner):
# support coredump list

to delete specific core file use:

# support coredump delete [corefile.filename]

to delete all of them use:

# support coredump delete all
      
3. Visa en lista över de supportpaket som lagras i systemet
# support bundle list

to delete specific support bundle 

# support bundle delete <bundle-name-list> 

to delete all support bundles

# support bundle delete all

4. Ansluta till Data Domain System Manager-webbkonsolens gränssnitt
5. Navigera till Underhållssystem >
6. Under tabellen "Upgrade Packages Available on Data Domain System" väljer du det uppgraderingspaket du hittar genom att markera rutan bredvid paketets filnamn
7. Klicka på knappen "Remove Upgrade Package" Frigör diskutrymme i mappen \ddvar med hjälp av ett Microsoft Windows-baserat system.
  1. Kontrollera att Data Domain-systemets åtkomstlista (ACL) är konfigurerad 181315 att åtkomst från det aktuella systemet tillåts.
  2. Ta bort gamla kärnfiler från Data Domain-systemet. Obs! Om värdnamnet inte fungerar kan du prova att använda IP-adressen i stället.
    ========== SERVERANVÄNDNING ==========
    Resursstorlek GiB Använda GiB Avail GiB Use%
    ------------------         --------        --------           ---------      ----
    /backup: före komp - 17814.5 - -
    /backup: efter komp 1892,9 1099,1 793,8 58 %
    /ddvar 19,7 3,2 16,5       12 %
    
    	
    1. I Windows-systemet klickar du på Start och välj Kör … och skriv IP-adressen (eller värdnamnet) och sökvägen till \ddvar-resursen.
      Kör kommando
      Klicka på OK
    2. Autentisera till DataDomain Restorer med något av följande konton för att ha fullständig behörighet för /ddvar-resursen:
      • Återställarens standardkonto för sysadmin
      • Annat lokalt konto för återställare som är en del av klassadministratören
        Bekräfta med kommandot # user show list
      • Active-Directory-administratörskonto som visar grupp-ID som 50
        Bekräfta med kommandot # cifs troubleshooting user 10500
    3. Ta bort kärnfiler om sådana finns. Öppna \kärna mapp.
      Kärnfiler
      • Om det finns kärnfiler listar du dem efter datum (detaljerad vy). Om det finns kärnfiler som är daterade under de senaste 24 timmarna kan det tyda på ett allvarligare problem som måste analyseras ytterligare. Om så är fallet kontaktar du din kontrakterade supportleverantör, laddar upp ett supportpaket (SUB) Link Error 180563 och den senaste kärnfilen när du har skapat en Skapa en tjänstebegäran
      • Om kärnfilerna inte är aktuella markerar du och tar bort alla filer.
    4. Ta bort gamla SUB-filer (Support Upload Bundle). Navigera till \ddvar\support mapp.
      Stöd för SUB-filer (Upload Bundle)
      • Markera och ta bort alla supportpaketfiler (support-bundle.tar.gz*)
    5. Ta bort gamla uppgraderingsfiler (.rpm filer) från Data Domain-systemet.
      Navigera till \ddvar\releases mapp. Markera och ta bort alla filer.
      Obs! .rpm Filerna används tillfälligt (endast under uppgraderingar). När systemet har uppgraderats behövs inte längre dessa filer.
    6. Kontrollera att utrymmet har återställts.
      Vid Data Domain-systemprompten skriver du:
      df
    Frigör diskutrymme i katalogen /ddvar med hjälp av ett Unix-baserat system.
    ========== SERVERANVÄNDNING ==========
    Resursstorlek GiB Använda GiB Avail GiB Use%
    ------------------         --------        --------           ---------      ----
    /backup: före komp - 17814.5 - -
    /backup: efter komp 1892,9 1099,1 793,8 58 %
    /ddvar 19,7 3,2 16,5       12 %
    
    
    1. Kontrollera att Data Domain-systemets NFS-åtkomstlista (ACL) är konfigurerad 181315 att tillåta åtkomst från det aktuella systemet.
    2. Montera /ddvar-exporten på klientsystemet. 181310
    3. Ta bort gamla kärnfiler (om sådana finns) från Data Domain-systemet.
      I NFS-klientsystemets kommandotolk skriver du:
      ls -l /ddvar/kärna
      • Om det finns kärnfiler som är daterade under de senaste 24 timmarna kan det tyda på ett allvarligare problem som måste analyseras ytterligare. Om så är fallet kontaktar du din kontrakterade supportleverantör, laddar upp ett supportpaket (SUB) Link Error 180563 och den senaste kärnfilen när du har skapat en Skapa en tjänstebegäran
      • Om kärnfilerna inte är aktuella tar du bort alla filer.
        rm /ddvar/core/*
    4. Ta bort gamla SUB-filer (Support Upload Bundle). I NFS-klientsystemets kommandotolk skriver du:
      rm /ddvar/support/support-bundle.*
    5. Ta bort gamla uppgraderingsfiler (.rpm filer)
      I NFS-klientsystemets kommandotolk skriver du:
      rm /ddvar/releases/*.rpm
    6. Kontrollera att utrymmet har återställts.
      Vid Data Domain-systemprompten skriver du:
      df
    Obs! Om /ddvar rapporterar fortfarande full efter att du har utfört stegen i den här artikeln, kontakta din kontrakterade supportleverantör, samla in ett 180561 för automatisk support och Skapa en tjänstebegäran

REFERENS

  • Tillfällig /ddvar-utrymmesanvändning ökar181878
  • Varningsberäkning för utrymme i /ddvar 180997


Obs! Länkarna i den här artikeln är endast avsedda för registrerade Dell-kunder.

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000043441
Article Type: Solution
Last Modified: 02 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.