ECS: Nelze odstranit prázdný kbelík s podporou CAS – chyba 1013 (HTTP: 400): Bad request body. Kbelík {} není prázdný.
Summary: Nelze odstranit kbelík s povoleným CAS, i když byly odstraněny všechny klipy v kbelíku.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Nelze odstranit prázdný kbelík s podporou CAS.
- Chyba 1013 (HTTP: 400): Bad request body. Bucket {} is not empty.
- ECS CAS: Žádný mechanismus pro tažení nebo čištění klipů odrazů.
- ECS CAS: Reflexní svorky zabraňující odstranění kbelíku CAS.

Cause
- Objekt CAS se skládá z jednoho klipu a jednoho nebo více objektů blob.
- Klip obsahuje metadata objektu, zatímco objekty blob obsahují samotný objekt.
- Když se odstraní objekt CAS, odstraní se klip i objekt blob a místo toho se vytvoří reflexe.
- Reflexe obsahuje metadata o objektu, který byl odstraněn, a je považován za objekt v kbelíku, i když nejsou uvedeny.
- Od verze ECS 3.2 byla do kbelíků CAS zavedena nová funkce s názvem "Reflection Expiration".
- Reflection Expiration umožňuje systému ECS ukončit platnost (odstranit/odstranit) odrazů v kbelíku po určité době od jejich vytvoření.
- Pokud není v kbelíku povolena možnost Reflection Expiration, vytvořené odrazy zůstanou v kbelíku po neomezenou dobu. Toznemožňuje vymazat kbelík, protože technicky není prázdný.
Resolution
Aby bylo možné kbelík správně vyprázdnit a poté úspěšně odstranit, musí být v kbelíku CAS povolena doba vypršení platnosti reflexe.
- Otevřete uživatelské rozhraní ECS.
- Přejděte na "Spravovat" v levém podokně.
- Vyberte "Buckets".
- Zvolte obor názvů, ve kterém je kbelík nakonfigurovaný.
- V tabulce v části "Actions" klikněte na "Edit Bucket" u kbelíku, který nelze odstranit.
- Klikněte na možnost "Povinné" v horní části
- Povolte "Reflection Expiration" stisknutím tlačítka "On" a následným výběrem hodnoty pro "Reflection Age".
Věk reflexe je doba, po kterou odraz zůstává v kbelíku po vytvoření (když je objekt odstraněn), než je
odebrán.Minimální hodnota pro "Věk odrazu" je 1 den. - Kliknutím na "Save" změny zachováte.
- Před dalším pokusem o odstranění kbelíku počkejte, dokud neuplyne doba nakonfigurovaná v části "Reflection Age".
- Pokud problém přetrvává, otevřete servisní požadavek u podpory ECS.
Před:
Po:
Additional Information
Přihlásit se k odběru novinek
o produktechNa stránce Soubory ke stažení se můžete přihlásit k odběru aktualizací tohoto produktu, abyste byli upozorněni vždy, když bude vydán soubor ke stažení, který řeší tento problém. Chcete-li se přihlásit k odběru aktualizací produktů Dell EMC, postupujte následovně:
o produktechNa stránce Soubory ke stažení se můžete přihlásit k odběru aktualizací tohoto produktu, abyste byli upozorněni vždy, když bude vydán soubor ke stažení, který řeší tento problém. Chcete-li se přihlásit k odběru aktualizací produktů Dell EMC, postupujte následovně:
- Na webu online podpory společnosti EMC vyberte možnost Podpora > podle produktu.
- V poli "Najít produkt" vyhledejte svůj produkt (pole se automaticky navrhne při psaní).
- Na stránce produktu vyberte možnost Soubory ke stažení. Tím přejdete na stránku Soubory ke stažení pro daný produkt.
- Kliknutím na "Přidat předplatné produktu" se přihlásíte k odběru aktualizací pro stránku.
Affected Products
ECS ApplianceProducts
ECS Appliance, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Software without Encryption, Elastic Cloud StorageArticle Properties
Article Number: 000044827
Article Type: Solution
Last Modified: 29 Oct 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.