ECS: Impossibile eliminare bucket vuoti abilitati per CAS - Errore 1013 (HTTP: 400): Corpo della richiesta non valido. Il bucket {} non è vuoto
Summary: Impossibile eliminare un bucket abilitato per CAS anche se tutte le clip nel bucket sono state eliminate.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Impossibile eliminare un bucket vuoto abilitato per CAS
- Errore 1013 (HTTP: 400): Corpo della richiesta non valido. Il bucket {} non è vuoto (in inglese).
- CAS ECS: Nessun meccanismo per spazzare o eliminare i clip di riflesso.
- CAS ECS: Clip di riflessione che impediscono l'eliminazione del bucket CAS.

Cause
- Un oggetto CAS è costituito da un clip e da uno o più BLOB.
- Il clip contiene i metadati dell'oggetto, mentre i BLOB contengono l'oggetto stesso.
- Quando viene eliminato un oggetto CAS, vengono eliminati sia il clip che il blob e viene invece creata una riflessione.
- La reflection contiene metadati sull'oggetto eliminato e viene trattata come oggetto nel bucket anche se non sono elencati.
- A partire da ECS 3.2, è stata introdotta una nuova funzione denominata "Reflection Expiration" per i bucket CAS.
- Reflection Expiration consente a ECS di far scadere (rimuovere/eliminare) i riflessi nel bucket dopo un determinato periodo di tempo dalla loro creazione.
- Se Reflection Expiration non è abilitata nel bucket, i riflessi creati rimarranno nel bucket a tempo indeterminato. Ciò rende impossibile eliminare il bucket in quanto non è tecnicamente vuoto.
Resolution
Reflection Expiration deve essere abilitato nel bucket CAS affinché il bucket venga svuotato correttamente e quindi eliminato correttamente.
- Aprire l'interfaccia utente di ECS.
- Vai su "Gestisci" nel riquadro a sinistra.
- Selezionare "Buckets".
- Scegliere il namespace in cui è configurato il bucket.
- Nella tabella, in "Actions", cliccare su "Edit Bucket" sul bucket che non può essere eliminato.
- Fai clic sull'opzione "Obbligatorio" in alto
- Abilitare "Reflection Expiration" premendo "On" e quindi scegliendo un valore per "Reflection Age".
L'età della riflessione corrisponde al tempo in cui la riflessione rimane nel bucket al momento della creazione (quando l'oggetto viene eliminato) prima della rimozione.
Il valore minimo per "Reflection Age" è 1 giorno. - Cliccare su "Save" per conservare le modifiche.
- Attendere che sia trascorso il tempo configurato in "Reflection Age" prima di provare a eliminare nuovamente il bucket.
- Se il problema persiste, aprire una Service Request con il supporto ECS.
Prima:
Dopo:
Additional Information
Iscriviti per ricevere gli aggiornamenti
del prodottoPuoi iscriverti agli aggiornamenti sulla pagina "Download" di questo prodotto in modo da ricevere una notifica ogni volta che viene rilasciato un download che risolve questo problema. Per effettuare la sottoscrizione agli aggiornamenti dei prodotti Dell EMC, effettuare le seguenti operazioni:
del prodottoPuoi iscriverti agli aggiornamenti sulla pagina "Download" di questo prodotto in modo da ricevere una notifica ogni volta che viene rilasciato un download che risolve questo problema. Per effettuare la sottoscrizione agli aggiornamenti dei prodotti Dell EMC, effettuare le seguenti operazioni:
- Sul sito del supporto online EMC, selezionare Support > Support By Product.
- Nel campo "Trova un prodotto", cerca il tuo prodotto (il campo verrà suggerito automaticamente durante la digitazione).
- Dalla pagina del prodotto, selezionare Downloads per accedere alla pagina Downloads relativa al prodotto.
- Cliccare su "Add Product Subscription" per registrarsi agli aggiornamenti della pagina.
Affected Products
ECS ApplianceProducts
ECS Appliance, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Software without Encryption, Elastic Cloud StorageArticle Properties
Article Number: 000044827
Article Type: Solution
Last Modified: 29 Oct 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.