ECS: GeoDrive: Error: 12029 – Spojení se serverem nelze navázat

Summary: Chyba služby GeoDrive: 12029 – Při přidávání systému ECS do klienta GeoDrive se zobrazí zpráva "A connection with the server could not be navázán".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Při přidávání systému ECS do klienta GeoDrive pro systém Windows podle uživatelské příručky se může během testování připojení po přidání IP adresy zobrazit chybová zpráva:

Error: 12029 - A connection with the server could not be established
Error: 12029 – Spojení se serverem nelze navázat 

Cause

Klient systému Windows nebo GeoDrive se nemůže připojit k systému ECS.

Resolution

Ověřte se zákazníkem, zda se používá nástroj pro vyrovnávání zatížení (LB) nebo zda je navázáno připojení přímo k uzlům ECS.

K testování připojení klienta Windows k datovému portu IP 9020 (HTTP) / 9021 (HTTPS) používejte nástroje jako telnet.
Pokud protokol telnet není v klientovi zákazníka se systémem Windows povolený, požádejte o dočasné povolení (funkce systému Windows) nebo použití klienta ve stejné podsíti.

Příklad:

C:\>telnet 10.1.1.1 9021
Connecting To 10.1.1.1...Could not open connection to the host, on port 9021: Connect failed

C:\>

Pokud připojení není možné, je třeba zkontrolovat následující kroky:

  • Zákazník se musí ujistit, že požadovaný port není blokován bránou firewall v prostředí zákazníka.
  • Je použita správná IP adresa ECS. Zajistěte, aby se v případě, že je na straně ECS povoleno oddělení sítě, používala datová IP adresa, a nikoli IP adresa pro správu.

Připojte se k systému ECS, ověřte, zda je povoleno oddělení sítě, a zkontrolujte datovou IP adresu:
Příklad:

admin@ecs1:~> getrackinfo -n
Named networks
==============
Node ID      Network           Ip Address     Netmask            Gateway         VLAN               Interface
1            repl              10.1.1.211     255.255.255.0      10.1.1.201      16                 public
1            data              10.1.2.202     255.255.255.0      10.1.2.201      123                public
2            repl              10.1.1.212     255.255.255.0      10.1.1.201      16                 public
2            data              10.1.2.203     255.255.255.0      10.1.2.201      123                public
3            repl              10.1.1.213     255.255.255.0      10.1.1.201      16                 public
3            data              10.1.2.204     255.255.255.0      10.1.2.201      123                public
4            repl              10.1.1.214     255.255.255.0      10.1.1.201      16                 public
4            data              10.1.2.205     255.255.255.0      10.1.2.201      123                public
5            repl              10.1.1.215     255.255.255.0      10.1.1.201      16                 public
5            data              10.1.2.206     255.255.255.0      10.1.2.201      123                public

Ve výše uvedeném příkladu by IP adresy 10.1.2.202 – 206 byly správné a bylo by nutné je použít pro konfiguraci klienta GeoDrive.

Níže uvedený soubor protokolu vám nakonec může pomoci při dalším odstraňování problémů vyhledáním IP adresy klienta Windows v tomto souboru. (Ve výše uvedeném případě se nezobrazí žádný pokus o připojení, protože Datahead nepřijímá žádné spojení):
 /opt/emc/caspian/fabric/agent/services/object/main/log/dataheadsvc.log

svc_log můžete použít také k vyhledání IP adresy klienta Windows ve všech protokolech dataheadsvc.logs na všech uzlech:

admin@ecs1:~> svc_log -f '10.x.x.x' -sr dataheadsvc -n all -sn -sf

Additional Information

Stejná chyba se může zobrazit, pokud jsou přihlašovací údaje uživatele nesprávně nakonfigurované.
1. ID uživatele by mělo být Object User.
2. Tajný přístupový klíč by měl být klíč S3 vygenerovaný pro uživatele objektu.

ID uživatele a tajný přístupový klíč můžete upravit podle následujících kroků z GeoDrive:
Stiskněte "přidat GeoDrive" >> hostitele >> Stiskněte na hostitele, kterého chcete upravit >> Upravit 

Affected Products

GeoDrive for Windows

Products

GeoDrive for Windows, ECS Appliance, Elastic Cloud Storage
Article Properties
Article Number: 000045612
Article Type: Solution
Last Modified: 30 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.