ECS: GeoDrive: Error: 12029 – Yhteyttä palvelimeen ei voitu muodostaa

Summary: GeoDrive-virhe: 12029 – "Yhteyttä palvelimeen ei voitu muodostaa" lisättäessä ECS GeoDrive-asiakkaaseen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kun lisäät ECS:n GeoDriven Windows-työasemaan käyttöoppaan mukaisesti, saatat nähdä virheilmoituksen yhteystestauksen aikana IP-osoitteen lisäämisen jälkeen:

Error: 12029 - A connection with the server could not be established
Error: 12029 – Yhteyttä palvelimeen ei voitu muodostaa 

Cause

Windows tai GeoDrive Client ei voi muodostaa yhteyttä ECS:ään.

Resolution

Varmista asiakkaalta, onko kuormituksentasaus (LB) käytössä vai muodostetaanko yhteys suoraan ECS-solmuihin.

Käytä työkaluja, kuten telnet, yhteyden testaamiseen Windows-asiakkaasta ECS-tietoihin IP-portti 9020 (HTTP) / 9021 (HTTPS).
Jos telnet ei ole käytössä asiakkaan Windows-työasemassa, pyydä saada ottaa (Windows-ominaisuudet) tilapäisesti käyttöön tai käyttää asiakasta samassa aliverkossa.

Esimerkki:

C:\>telnet 10.1.1.1 9021
Connecting To 10.1.1.1...Could not open connection to the host, on port 9021: Connect failed

C:\>

Jos yhteyden puuttuminen ei ole mahdollista, on tarkistettava seuraavat vaiheet:

  • Asiakkaan on varmistettava, että vaadittua porttia ei ole estetty palomuurilla asiakasympäristössä.
  • Käytössä on oikea ECS:n IP-osoite. Varmista, että tietojen IP-osoitetta käytetään, jos verkon erottelu on käytössä ECS-puolella, eikä hallinnan IP-osoitetta.

Muodosta yhteys ECS:ään ja tarkista, onko verkon erottelu käytössä, ja tarkista tiedot IP-osoite:Esimerkki:

admin@ecs1:~> getrackinfo -n
Named networks
==============
Node ID      Network           Ip Address     Netmask            Gateway         VLAN               Interface
1            repl              10.1.1.211     255.255.255.0      10.1.1.201      16                 public
1            data              10.1.2.202     255.255.255.0      10.1.2.201      123                public
2            repl              10.1.1.212     255.255.255.0      10.1.1.201      16                 public
2            data              10.1.2.203     255.255.255.0      10.1.2.201      123                public
3            repl              10.1.1.213     255.255.255.0      10.1.1.201      16                 public
3            data              10.1.2.204     255.255.255.0      10.1.2.201      123                public
4            repl              10.1.1.214     255.255.255.0      10.1.1.201      16                 public
4            data              10.1.2.205     255.255.255.0      10.1.2.201      123                public
5            repl              10.1.1.215     255.255.255.0      10.1.1.201      16                 public
5            data              10.1.2.206     255.255.255.0      10.1.2.201      123                public

Edellä olevassa esimerkissä IP-osoitteet 10.1.2.202–206 ovat oikein, ja niitä on käytettävä GeoDrive-asiakaskokoonpanossa.

Alla olevasta lokitiedostosta voi lopulta olla apua lisävianmäärityksessä etsimällä Windows-asiakkaan IP-osoite tästä tiedostosta. (yllä olevassa tapauksessa yhteysyritystä ei näy, koska datahead ei saa yhteyttä):
 /opt/emc/caspian/fabric/agent/services/object/main/log/dataheadsvc.log

Voit myös käyttää svc_log Windows-asiakkaan IP-osoitteen hakemiseen kaikkien solmujen dataheadsvc.log-tiedostoista:

admin@ecs1:~> svc_log -f '10.x.x.x' -sr dataheadsvc -n all -sn -sf

Additional Information

Sama virhe voi ilmetä, jos käyttäjän tunnistetiedot on määritetty väärin.
1. Käyttäjätunnuksen tulee olla objektikäyttäjä.
2. Salaisen käyttöoikeusavaimen tulee olla objektin käyttäjälle luotu S3-avain.

Voit muokata käyttäjätunnusta ja salaista pääsyavainta seuraavasti GeoDrivessa:
Paina "lisää GeoDrive" >> -isäntiä >> Paina isäntää, jota haluat muokata >> Muokkaa 

Affected Products

GeoDrive for Windows

Products

GeoDrive for Windows, ECS Appliance, Elastic Cloud Storage
Article Properties
Article Number: 000045612
Article Type: Solution
Last Modified: 30 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.