Analyse sur cluster Isilon - Adresse IP du service SmartConnect

Summary: Cet article contient de nombreuses références pour corriger l’adresse IP du service SmartConnect après une mise à niveau vers OneFS 8.2.0.0.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Isilon On-Cluster Analysis génère un résultat similaire à ce qui suit :

SmartConnect Service IP                           FAIL
  FAIL: The following SmartConnect Service IP Address(es) could not be located on any node: 192.168.1.1
  CRITICAL: Found client(s) connected to a SmartConnect Service IP address (SSIP), this is not supported and will stop working after the upgrade to 
        OneFS 8.2.0.0. For details on why it will no longer work in OneFS 8.2 or later see LKB000078817 [OneFS 8.2: Error "403: Forbidden - Accessing OneFS web administration interface over a configured SmartConnect service IP address is forbidden"]
  CRITICAL: Immediately following the commit of the upgrade to OneFS 8.2.0.0, the SmartConnect Service IP addresses associated with subnets that have
        VLAN tagging may disappear. Shortly after the Userspace rollup patch install is started this issue should go away. Please plan accordingly for
        there to be a disruption to new connection requests at this stage in the OneFS upgrade. For more details on this issue please review LKB000168627
        [{ISILON} Smartconnect Service IP Address (SSIP) goes missing on all configured VLAN interfaces after committing OneFS 8.2 upgrade]
  CRITICAL: Found SC Zone Name(s) and/or SC DNS Zone Alias(es) that are configured to use a DNS short name as opposed to a fully qualified domain name, this
        is not supported and will stop working after the upgrade to OneFS 8.2.0.0. For details on why it will no longer work in OneFS 8.2 or later see 
        LKB000173410 [OneFS distributed file system 8.2: If using short name/Literal instead of fully qualified domain name (FQDN), Smartconnect refuses any queries]

Cause

Impossible de trouver l’adresse IP du service SmartConnect suivante sur un nœud : 192.168.1.1

La ou les adresses SSIP répertoriées n’ont pu se trouver sur aucun des nœuds du cluster.  Cela peut entraîner une indisponibilité des données.

Pour rechercher manuellement une adresse SSIP, exécutez la commande suivante et remplacez <SSIP> par l’adresse SSIP à rechercher :
isi_for_array ifconfig | grep <SSIP>
Pour résoudre les problèmes liés à SmartConnect, commencez par suivre le Guide de dépannage client EMC Isilon - Dépanner votre configuration SmartConnect

Resolution

 

Clients détectés connectés à une adresse IP du service SmartConnect (SSIP). Cette opération n’est pas prise en charge et cessera de fonctionner après la mise à niveau vers OneFS 8.2.0.0. Pour plus d’informations sur les raisons pour lesquelles il ne fonctionnera plus dans OneFS 8.2 ou versions ultérieures, reportez-vous à LKB000078817 [OneFS 8.2 : Erreur « 403 : Interdit : l’accès à l’interface d’administration Web OneFS via une adresse IP de service SmartConnect configurée est interdit. »]

L’adresse IP du service SmartConnect est conçue uniquement pour les recherches DNS. Les tâches d’administration et d’accès aux données client ne doivent pas transiter par les adresses SSIP. Pour plus d’informations sur les raisons pour lesquelles il ne fonctionnera plus dans OneFS 8.2 ou versions ultérieures, reportez-vous à LKB000078817 [OneFS 8.2 : Erreur « 403 : Interdit : l’accès à l’interface d’administration Web OneFS via une adresse IP de service SmartConnect configurée est interdit. »]

Immédiatement après la validation de la mise à niveau vers OneFS 8.2.0.0, les adresses IP du service SmartConnect associées aux sous-réseaux dotés d’un balisage VLAN peuvent disparaître. Peu de temps après le démarrage de l’installation du correctif cumulatif de l’espace utilisateur, ce problème devrait disparaître. Veuillez prévoir en conséquence qu’il y aura une interruption des nouvelles demandes de connexion à ce stade de la mise à niveau de OneFS. Pour plus d’informations sur ce problème, consultez LKB000168627 [L’adresse IP du service SmartConnect (SSIP) {{ISILON} disparaît sur toutes les interfaces VLAN configurées après la validation de la mise à niveau de OneFS 8.2]

Si vous avez trouvé des nom(s) de zone SC et/ou des alias de zone DNS SC configurés pour utiliser un nom abrégé DNS plutôt qu’un nom de domaine complet, cela n’est pas pris en charge et cessera de fonctionner après la mise à niveau vers OneFS 8.2.0.0. Pour plus d’informations sur la raison pour laquelle il ne fonctionnera plus dans OneFS 8.2 ou versions ultérieures, reportez-vous LKB000173410 [OneFS distributed file system 8.2 : Si vous utilisez un nom abrégé/littéral au lieu d’un nom de domaine complet (FQDN), SmartConnect refuse toutes les requêtes.]

Consultez l’article de la base de connaissances suivant pour plus d’informations sur ce problème : OneFS 8.2 si vous utilisez (nom abrégé/littéral) au lieu de FQDN SmartConnect refuse toutes les requêtes

Additional Information

Pour exécuter uniquement la vérification de l’adresse IP du service SmartConnect et recueillir des informations supplémentaires, exécutez IOCA avec les arguments supplémentaires : -e --run=checkSmartConnect

Voici un exemple :
# perl /usr/libexec/isilon/ioca/IOCA --run=checkSmartConnect -e
Isilon On-Cluster Analysis                        0.1250
Live Cluster Analysis                             Wed Jul 10 17:22:56 2019
Cluster Name                                      Isilon
Cluster GUID                                      0000000000000000000000000000000000000
Node Count                                        3
Current OneFS Version                             8.2.0.0
SmartConnect Service IP                           FAIL
  CRITICAL: Found SC Zone Name(s) and/or SC DNS Zone Alias(es) that are configured to use a DNS short name as opposed to a fully qualified domain
        name, this is not supported and will stop working after the upgrade to OneFS 8.2.0.0. For details on why it will no longer work in OneFS 8.2
        or later see KB 534584 [https://support.emc.com/kb/534586 - OneFS 8.2 if using (short name/Literal) instead of FQDN smartconnect refuses any queries]

  ==============================
  Clients Connected to SSIPs
  ==============================
    LNN Local Address                  Remote Address
  ----- ------------------------------ ------------------------------

  ==============================
  SmartConnect Short Names
  ==============================
  Pool: groupnet0.subnet0.pool0, DNS Short Names: Isilon

  ==============================
  SmartConnect Service IP Locations
  ==============================
  SSIP                 LNN   Network Interface
  -------------------- ----- ----------
  192.168.1.1          1     lagg1

 

Affected Products

Isilon

Products

Isilon
Article Properties
Article Number: 000049446
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  6
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