NVP-vProxy: VMs are not getting all disks backed up (Skipping disk 2002 "Hard disk 3" not explicitly referenced in the backup request.)

Summary: VMs are not getting all disks backed up. Skipping disk 2002 "Hard disk 3" is not explicitly referenced in the backup request.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection integration is configured with the vProxy Appliance. The backup skips certain disks on specific Virtual Machines (VM). The backup workflow log shows:

YYYY/MM/DD HH:MM:SS NOTICE: [@(#) Build number: 189] Skipping disk 2002 "Hard disk 3" not explicitly referenced in the backup request.
YYYY/MM/DD HH:MM:SS NOTICE: [@(#) Build number: 189] Skipping disk 2003 "Hard disk 4" not explicitly referenced in the backup request.
YYYY/MM/DD HH:MM:SS NOTICE: [@(#) Build number: 189] Skipping disk 2004 "Hard disk 5" not explicitly referenced in the backup request.
YYYY/MM/DD HH:MM:SS TRACE:  [@(#) Build number: 189] Backing up 2 virtual disks...

 

Cause

The VMware snapshot creation does not allow snapshots of "Independent Persistent Disks," so the vProxy backup workflow skips the disks. The vProxy backup workflow requires a snapshot of the virtual disk to perform the VM backup.

 

Resolution

The Independent disks support information is documented in the "NetWorker VMware Protection Solution best practices with the vProxy Appliance" of the Dell Technologies NetWorker VMware Integration Guide:

When you plan the backups, ensure that NetWorker VMware Protection supports the disk types that you use in the environment. Currently, NetWorker VMware Protection does not support the following disk types:

  • Independent (persistent and non-persistent)
  • RDM Independent - Virtual Compatibility Mode
  • RDM Physical Compatibility Mode

 

Affected Products

NetWorker Family

Products

NetWorker Series
Article Properties
Article Number: 000050202
Article Type: Solution
Last Modified: 23 Sep 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.