PowerFlex 3.X Gateway's "Collect Logs" and "Analyze System" buttons do not work
Summary: After "Retrieve Topology" in GW, clicking the "Collect Logs" and "Analyze System" buttons does nothing.
Symptoms
Scenario
Gateway version 3.0.0.x
There are ESXi SDCs, some of which are shown as "IP: N/A"
Symptoms
With ESXi SDCs present in the system, after clicking the "Collect Logs" button, a dialog should pop up, asking to enter ESXi passwords. With this issue, this dialog does not pop up, preventing the log collection from proceeding.
Impact
Unable to collect logs using GW.
Cause
Root Cause
The ESXi SDCs with "IP: N/A" causes the javascript to fail to proceed the list.
SDC ID: <sdc id> Name: <sdc name> IP: N/A State: Disconnected GUID: <sdc guid> OS Type: ESXi Loaded Version: 2.5.0 Installed Version: 2.5.0
Resolution
Workaround
Usually SDCs with "IP: N/A" is not used anymore. If possible, remove all of them which have "OS Type: ESXi" from ScaleIO, using scli or UI; if not possible, manually collect logs.
Additional Information
Impacted Versions
3.0.0.x
Fixed In Version
3.0.1 The dialog will pop up, with a warning that some nodes may be missing.
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