SourceOne Email Management - Søk utelater resultater når du søker etter datoer etter konvertering av indekser fra ISYS til ElasticSearch
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Du har konfigurert ElasticSearch på en ISYS Archive-mappe og konvertert indekssettene til ElasticSearch-typen.
Etter konvertering gir søk mellom bestemte datoperioder i de konverterte indeksene ingen resultater, eller elementer for bestemte datoer vises ikke i resultatene.
Ingen feil logges i SourceOne-loggene eller Websearch.
Dette problemet påvirker bare kunder som har migrert til ElasticSearch fra en ISYS-arkivmappe.
Under overføringen slås ISYS-indekser sammen til 1 enkelt ElasticSearch-indeks, men oppdateres ikke MsgStartDate og MsgEndDate riktig.
MsgStartDate og MsgEndDate er feil angitt basert på det siste indekssettet som er slått sammen i indekssettet, mens det bør angis basert på datointervallet for alle meldingene i ElasticSearch-indekssettet.
Hvis datosøkekriteriene faller ut av MsgStartDate og MsgEndDate, inkluderes ikke indeksen i søket, og gir derfor ikke resultater fra denne indeksen.
For eksempel:
ElasticSearch-indeksen for februar 2017 har feilaktig angitt MsgStartDate 20-02-2017 og MsgEndDate 28-02-2017.
Hvis en bruker søker med en datoperiode på 1. januar 2017 og 15. februar, vil resultatene bare vise elementene som ble funnet i januar, da indeksen for februar ikke vil bli inkludert i søket.
Cause
Dette problemet skyldes en programvarefeil.
Resolution
Dette problemet er løst i hurtigreparasjonspakker eller Service Pack-versjoner på eller høyere enn 7.2.5.5088. (7.2.5 GA).
Dette problemet er løst i hurtigreparasjonspakker (HFB-er) eller Service Pack-versjoner på eller høyere enn SourceOne Email Management 7.2.5.6201. (7.2.6 + HFB 3)
Hurtigreparasjonspakker og Service Pack-sett er tilgjengelig for nedlasting via https://www.dell.com/support, Velg "Drivere og nedlastinger" for å få tilgang til nødvendig programvare
* Vær oppmerksom på at hurtigreparasjoner bare er tilgjengelige for de nyeste oppdateringene eller Service Pack-versjonene av produktet som var tilgjengelige da dette problemet ble løst.
** Vær oppmerksom på at når du installerer hurtigreparasjonspakker (HFB-er), må alle installeres i riktig rekkefølge for at ALLE feilrettinger skal brukes riktig.
*** Vær oppmerksom på at det alltid anbefales å oppgradere til den nyeste versjonen av SourceOne-utgaven, Service Pack og hurtigreparasjonsbunten for å sikre at alle løste problemer blir løst, inkludert problemet som er oppgitt ovenfor.
Dette problemet er løst i hurtigreparasjonspakker (HFB-er) eller Service Pack-versjoner på eller høyere enn SourceOne Email Management 7.2.5.6201. (7.2.6 + HFB 3)
Hurtigreparasjonspakker og Service Pack-sett er tilgjengelig for nedlasting via https://www.dell.com/support, Velg "Drivere og nedlastinger" for å få tilgang til nødvendig programvare
* Vær oppmerksom på at hurtigreparasjoner bare er tilgjengelige for de nyeste oppdateringene eller Service Pack-versjonene av produktet som var tilgjengelige da dette problemet ble løst.
** Vær oppmerksom på at når du installerer hurtigreparasjonspakker (HFB-er), må alle installeres i riktig rekkefølge for at ALLE feilrettinger skal brukes riktig.
*** Vær oppmerksom på at det alltid anbefales å oppgradere til den nyeste versjonen av SourceOne-utgaven, Service Pack og hurtigreparasjonsbunten for å sikre at alle løste problemer blir løst, inkludert problemet som er oppgitt ovenfor.
Additional Information
Dette problemet er løst slik at MsgStartDate og MsgEndDate i FTindex-tabellen er riktig angitt basert på en spørring sendt direkte til ElasticSearch-indeksen under konverteringen fra ISYS til ElasticSearch.
Endringer er implementert i funksjonen Indeksvalidering for å løse problemer forårsaket av feil datoperioder i FTInex-tabellen. Indeksvalideringsnivå 1 sjekker FTInex-datoperiodene mot den faktiske datoperioden for dokumenter i ElasticSearch-indeksen og oppdaterer FTInex-datoperioden når det er nødvendig for å samsvare med ElasticSearch.
Hvis indeksvalidering allerede er konfigurert i systemet, må du sørge for at du utløser en manuell skanning av indeksene. I henhold til dokumentasjon vil planlagte indeksskanninger hoppe over de indekssettene som allerede er skannet, og det ikke har blitt oppdatert siden forrige skanning.
Endringer er implementert i funksjonen Indeksvalidering for å løse problemer forårsaket av feil datoperioder i FTInex-tabellen. Indeksvalideringsnivå 1 sjekker FTInex-datoperiodene mot den faktiske datoperioden for dokumenter i ElasticSearch-indeksen og oppdaterer FTInex-datoperioden når det er nødvendig for å samsvare med ElasticSearch.
Hvis indeksvalidering allerede er konfigurert i systemet, må du sørge for at du utløser en manuell skanning av indeksene. I henhold til dokumentasjon vil planlagte indeksskanninger hoppe over de indekssettene som allerede er skannet, og det ikke har blitt oppdatert siden forrige skanning.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000052131
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.