Управление электронной почтой SourceOne - Поиск пропускает результаты при поиске по датам после преобразования индексов из ISYS в ElasticSearch
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Вы настроили ElasticSearch для папки архива ISYS и преобразовали ее наборы индексов в тип ElasticSearch.
После преобразования поиск между определенными диапазонами дат в преобразованных индексах не дает результатов или элементы для определенных дат не отображаются в результатах.
В журналах SourceOne и в Websearch ошибки не регистрируются.
Эта проблема затрагивает только заказчиков, которые перешли в ElasticSearch из архивной папки ISYS.
Во время переноса индексы ISYS объединяются в 1 индекс ElasticSearch, но MsgStartDate и MsgEndDate не обновляются должным образом.
MsgStartDate и MsgEndDate неправильно заданы на основе последнего набора индексов, объединенного с набором индексов, тогда как они должны быть заданы на основе диапазона дат всех сообщений в наборе индексов ElasticSearch.
Если критерии поиска по дате выпадают из MsgStartDate и MsgEndDate, индекс не включается в поиск, поэтому результаты из этого индекса не предоставляются.
Например:
В индексе ElasticSearch за февраль 2017 г. неправильно установлены MsgStartDate 20-02-2017 и MsgEndDate 28-02-2017.
Если пользователь ищет с диапазоном дат 1 января 2017 года и 15 февраля, в результатах будут показаны только элементы, найденные в январе, так как индекс за февраль не будет включен в поисковый запрос.
Cause
Эта проблема вызвана дефектом программного обеспечения.
Resolution
Эта проблема устранена в пакетах исправлений или пакетах обновления версий 7.2.5.5088 или выше. (7.2.5 ГА).
Эта проблема устранена в пакетах исправлений (HFB) или пакетах обновления версий SourceOne Email Management 7.2.5.6201 или выше. (7.2.6 + HFB 3)
Пакеты исправлений и комплекты обновлений доступны для загрузки через https://www.dell.com/support. Выберите раздел «Драйверы и загружаемые материалы», чтобы получить доступ к необходимому программному обеспечению
*. Обратите внимание, что оперативные исправления доступны только для последних версий исправлений или пакетов обновлений, которые были доступны на момент решения этой проблемы.
** Обратите внимание, что пакеты исправлений (HBB) нужно устанавливать в правильном порядке, чтобы ВСЕ исправления были правильно применены.
*** Обратите внимание, что всегда рекомендуется выполнять модернизацию до последней версии выпуска SourceOne, пакета обновления и комплекта Hot Fix, чтобы убедиться, что все текущие проблемы будут устранены, включая проблему, описанную выше.
Эта проблема устранена в пакетах исправлений (HFB) или пакетах обновления версий SourceOne Email Management 7.2.5.6201 или выше. (7.2.6 + HFB 3)
Пакеты исправлений и комплекты обновлений доступны для загрузки через https://www.dell.com/support. Выберите раздел «Драйверы и загружаемые материалы», чтобы получить доступ к необходимому программному обеспечению
*. Обратите внимание, что оперативные исправления доступны только для последних версий исправлений или пакетов обновлений, которые были доступны на момент решения этой проблемы.
** Обратите внимание, что пакеты исправлений (HBB) нужно устанавливать в правильном порядке, чтобы ВСЕ исправления были правильно применены.
*** Обратите внимание, что всегда рекомендуется выполнять модернизацию до последней версии выпуска SourceOne, пакета обновления и комплекта Hot Fix, чтобы убедиться, что все текущие проблемы будут устранены, включая проблему, описанную выше.
Additional Information
Эта проблема была исправлена, чтобы MsgStartDate и MsgEndDate в таблице FTindex были правильно заданы на основе запроса, отправленного непосредственно в индекс ElasticSearch во время преобразования из ISYS в ElasticSearch.
В функцию проверки индекса были внесены изменения для устранения проблем, вызванных неправильными диапазонами дат в таблице FTIndex. Индекс уровня проверки 1 сверяет диапазоны дат FTIndex с фактическим диапазоном дат документов в индексе ElasticSearch и при необходимости обновляет диапазон дат FTIndex в соответствии с ElasticSearch.
Если в системе уже настроена проверка индексов, обязательно запустите сканирование индексов вручную. Согласно документации, при запланированном сканировании индексов будут пропускаться уже проверенные наборы индексов и не обновлявшиеся с момента последнего сканирования.
В функцию проверки индекса были внесены изменения для устранения проблем, вызванных неправильными диапазонами дат в таблице FTIndex. Индекс уровня проверки 1 сверяет диапазоны дат FTIndex с фактическим диапазоном дат документов в индексе ElasticSearch и при необходимости обновляет диапазон дат FTIndex в соответствии с ElasticSearch.
Если в системе уже настроена проверка индексов, обязательно запустите сканирование индексов вручную. Согласно документации, при запланированном сканировании индексов будут пропускаться уже проверенные наборы индексов и не обновлявшиеся с момента последнего сканирования.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000052131
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.