Dell EMC Unity: Error Code "flr::check_server_connectivity_2" during Pre-Upgrade Health Checks (User Correctable)
Summary: The health check process has determined that one or more servers do not have redundant communication paths. This error is raised to allow customers to take action to prevent data unavailable or data loss condition during a Service Processor reboot or failover. ...
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Symptoms
Unable to Upgrade a Unity system due to a problem with host connectivity. Pre-Upgrade Health Check failed with error code: "flr::check_server_connectivity_2"
"The health check has failed. If an SP has to fail over, one or more of your servers do not have redundant communication paths and could cause data unavailable or data loss errors. Record the error code and search the EMC Online Support website for available support options."
One or more hosts do not have connections to both SPs. This could result in data loss or unavailability during an upgrade.
"The health check has failed. If an SP has to fail over, one or more of your servers do not have redundant communication paths and could cause data unavailable or data loss errors. Record the error code and search the EMC Online Support website for available support options."
One or more hosts do not have connections to both SPs. This could result in data loss or unavailability during an upgrade.
Cause
Before an upgrade on a Unity array there are advanced health checks that take place to ensure that the system upgrade runs smoothly.
Note:
This message means that if you attempt to proceed with the upgrade with the Unity array in this current state, at least one (or more) of your hosts lose access to the storage array, resulting in servers failing.
This safeguard within the Unity OE code is designed to help protect your environment.
Note:
- A Unity upgrade requires the Storage Processors (SP) to be rebooted, however each SP is rebooted separately.
- This is to prevent any disruption of I/O to Hosts.
- A host must be connected to the correct ports on both SPs because each SP will be rebooted during the upgrade.
This message means that if you attempt to proceed with the upgrade with the Unity array in this current state, at least one (or more) of your hosts lose access to the storage array, resulting in servers failing.
This safeguard within the Unity OE code is designed to help protect your environment.
Resolution
In order to resolve this problem:
- Investigate the host connectivity by browsing the following setting within Unisphere: "Access" -> "Hosts."
- Check the Health page and ensure that cables to hosts are connected to the corresponding Ethernet ports on both SPs.
- Host X is connected to the same Ethernet port on both SPs.
- Power down any hosts for which redundant paths cannot be established.
When all active hosts have redundant connections to both SPs this health check will not be triggered anymore.
Caution: It is not recommended to skip this pre-upgrade health check due to the risk of data corruption.
Additional Information
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
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Article Properties
Article Number: 000052357
Article Type: Solution
Last Modified: 14 Mar 2025
Version: 5
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