Uživatelské rozhraní nástroje DD System Manager Tomcat: Řešení chyby: MSG-PMON-00012: Nelze restartovat
Summary: Tento článek znalostní databáze podrobněji popisuje chybu výstrahy procmon: MSG-PMON-00012: Nelze restartovat soubor /ddr/bin/sm_em. Nastavení stavu FAILED, které se může generovat ve verzích DDOS 6.0 A 6.1. ...
Symptoms
Vydat
Problém s přístupem k uživatelskému rozhraní Správce systému nebo se zobrazí následující výstraha:ddr_procmon: ALERT: MSG-PMON-00012: Cannot restart /ddr/bin/sm_em. Setting state to FAILED.
Výstraha se zobrazí na samotné konzole a v messages.engineering.
V části se nezobrazí žádné výstrahy #alerts show current
Poznámka: Tato výstraha byla také pozorována u DDVE
Výstraha procmon se běžně vyskytuje;
- Po upgradu systému DDOS
- Po restartování systému
- Po restartu webových služeb http, tj. adminaccess povolit http
- Po spuštění dalších příkazů AdminAccess
Cause
Úkolem Procmona je restartovat proces, pokud selhal nebo byl ukončen. A pokud proces opakovaně selhává, procmon na to upozorní.
Dřívější verze:
Procmon byl nakonfigurován tak, aby monitoroval proces sm_em. Když sm_em zemře, procmon jej restartuje.
sm_em interně spustí Apache inline sm_em na tomto řádku stále čeká, dokud Apache neběží. Pokud se Apache z jakéhokoli důvodu ukončí, sm_em se přesune vpřed a ukončí. Procmon monitoruje sm_em, restartuje sm_em a v důsledku toho je Apache znovu spuštěn sm_em.
Co se změnilo v poslední verzi:
sm_em je spouštění Apache na pozadí. Proto nezastaví provádění sm_em. sm_em se pohne kupředu a skončí.
Procmon stále monitoruje sm_em. Restartuje sm_em a pokaždé vyvolá upozornění sm_em když ukončuje.
Resolution
Alternativní řešení
Restartování webové služby systému jejich zakázáním a opětovným povolením pomocí níže uvedených příkazů v příkazovém řádku DD CLI nebo Putty může vyvolat uživatelské rozhraní, pokud je nepřístupné, ale nepotlačí výstrahy:ddr## adminaccess disable httpddr## adminaccess disable httpsddr## adminaccess enable httpddr## adminaccess enable https
Výše uvedené příkazy by měly restartovat služby tomcat. Otevřete uživatelské rozhraní nástroje DD System Manager a zkontrolujte stav.
Pokud problém přetrvává, obraťte se na podporu společnosti Dell a přečtěte si tento článek.
Usnesení
Upgradujte na nejnovější verzi systému DDOS a získejte opravy.