DD System Manager UI Tomcat: Fout oplossen: MSG-PMON-00012: Kan niet opnieuw opstarten

Summary: In dit KB-artikel wordt de procmon alert Error in meer detail beschreven: MSG-PMON-00012: Kan /ddr/bin/sm_em niet opnieuw opstarten. De status instellen op FAILED wat kan worden gegenereerd op DDOS 6.0 EN 6.1 releases. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uitgeven

Probleem met toegang tot de gebruikersinterface van System Manager of de volgende waarschuwing wordt weergegeven:
ddr_procmon: ALERT: MSG-PMON-00012: Cannot restart /ddr/bin/sm_em. Setting state to FAILED.

De waarschuwing is te zien op de console zelf en in berichten.engineering.
Er worden geen waarschuwingen weergegeven in #alerts show current

Opmerking: Deze waarschuwing is ook waargenomen met DDVE

De procmon-waarschuwing wordt vaak gezien;

  • Na DDOS-upgrade
  • Na het opnieuw opstarten van het systeem
  • Na het opnieuw opstarten van de http-webservices, d.w.z. adminaccess enable http
  • After running other adminaccess commands

Cause

Het is de taak van Procmon om een proces opnieuw te starten als het is mislukt/afgesloten. En als een proces herhaaldelijk mislukt, geeft procmon er een waarschuwing over.

Eerdere releases:
Procmon is geconfigureerd om het sm_em proces te bewaken. Wanneer sm_em sterft, start procmon het opnieuw op.
sm_em start Apache inline intern, sm_em blijft op deze regel wachten tot Apache actief is. Als Apache om welke reden dan ook stopt, gaat sm_em verder en exit. Procmon monitort sm_em, het start opnieuw op sm_em en als gevolg daarvan wordt Apache opnieuw gestart door sm_em.

Wat is er veranderd in de laatste release:
sm_em is het starten van Apache op de achtergrond. Daarom stopt het de uitvoering van sm_em niet. sm_em gaat vooruit en stopt ermee.
Procmon houdt sm_em nog steeds in de gaten. Het start sm_em opnieuw op en geeft een waarschuwing wanneer sm_em elke keer blijft stoppen.

Resolution

Tijdelijke oplossing

Door de webservice van het systeem opnieuw op te starten door ze uit te schakelen en vervolgens weer in te schakelen met behulp van de onderstaande opdrachten op DD CLI of Putty, kan de gebruikersinterface worden weergegeven als deze niet toegankelijk is, maar worden de waarschuwingen niet onderdrukt:

ddr## adminaccess disable http
ddr## adminaccess disable https
ddr## adminaccess enable http
ddr## adminaccess enable https

Bovenstaande opdrachten zouden de tomcat-services opnieuw moeten starten. Open de DD System Manager UI om de status te controleren. 

Als het probleem zich blijft voordoen, neemt u contact op met Dell Support en raadpleegt u dit artikel. 

 

Resolutie

Upgrade naar de nieuwste DDOS-release voor oplossingen

Affected Products

Data Domain

Products

Data Domain, Data Domain Boost
Article Properties
Article Number: 000052791
Article Type: Solution
Last Modified: 06 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.