Avamar VM 映像備份已完成,並出現例外狀況/警告:avvcbimage 警告 <16277>:vSphere 工作失敗 (應用程式靜止)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Avamar VM 映像備份已完成,並出現例外狀況/警告:avvcbimage 警告 <16277>:vSphere 工作失敗 (應用程式靜止狀態)

應用程式靜止一致的快照失敗。

備份記錄中的相關部分:

2018-12-20 19:25:32 avvcbimage 警告 <16277>: vSphere 工作失敗 (應用程式靜止):「在靜止虛擬機器時發生錯誤。有關詳細資訊,請參閱虛擬機的事件日誌。 2018-12-20 19:25:32 avvcbimage 警告 <43652>:為虛擬機器「[<DATASTORE_NAME>] <PATH_TO_VMs_FILES.vmx>」建立快照「Avamar-XXXXXXXXX」時發生靜止問題 2018-12-20 19:25:32 avvcbimage 警告 <43656>:應用程式一致的快照靜止失敗。 2018-12-20 19:25:32 avvcbimage 警告 <43657>:VM 無法在建立快照之前靜止,而且如果成功,此備份可能不會作為後續 CBT 備份的基礎。 2018-12-20 19:25:32 avvcbimage 警告 <40711>:請考慮使用凍結前和解凍後指令檔,以利 VM 靜止 2018-12-20 19:25:32 avvcbimage 警告 <41146>:此錯誤可能是由預凍結腳本返回非零錯誤代碼引起的。


從資料存放區中 VM 資料夾的vmware.log通訊記錄:

2018-12-20T19:25:29.679Z|VMX|I125:快照:SnapshotPrepareTakeDoneCB:準備階段完成 (作業已成功完成)。 2018-12-20T19:25:29.773Z|vCPU-0|I125:工具備份:變更靜止狀態:閒置 -> 已開始 2018-12-20T19:25:30.777Z|VMX|I125:Msg_Post:儆 2018-12-20T19:25:30.777Z|VMX|I125:[msg.snapshot.quiesce.vmerr] 客體作業系統在靜止期間回報錯誤。 2018-12-20T19:25:30.777Z|VMX|I125+ 錯誤代碼為:3 2018-12-20T19:25:30.777Z|VMX|I125+ 錯誤訊息為:不支援嘗試的操作。 2018-12-20T19:25:30.777Z|VMX|I125:---------------------------------------- 2018-12-20T19:25:30.780Z|VMX|I125:工具備份:變更靜止狀態:已開始 -> ERROR_WAIT


Cause

VM 設定不正確,缺少「disk.「VM 選項」中的 EnableUUID=TRUE」屬性。
如果作業系統類型為 Windows Server 2016 的虛擬機器是使用主機用戶端建立,可能會發生這種情況。

Resolution

新增虛擬機器磁碟。「VM 選項」中的手動 EnableUUID = TRUE 屬性。

距離 https://kb.vmware.com/s/article/52815 的步驟
  1. 開啟 主機用戶端,然後登入 ESXi。
  2. 找出有問題的 Windows Server 2016 虛擬機器,並將其關閉電源。
  3. 關閉電源後,右鍵按兩下虛擬機,然後選擇 編輯設置。
  4. 按一下 VM 選項 標籤,然後選取 進階
  5. 組態參數,按一下編輯組態。
  6. 一下新增 參數。
  7. 金鑰 欄中,輸入 disk。EnableUUID。
  8. “值”列中,鍵入 TRUE。
  9. 按一下 確定 ,然後按 一下儲存
  10. 開啟虛擬機器電源。

Additional Information

如需詳細資訊,請參閱 VMware 知識庫:https://kb.vmware.com/s/article/52815

Affected Products

Avamar

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000053007
Article Type: Solution
Last Modified: 03 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.