Dell Unity: Expansor de SAS con fallas después del reemplazo del SP
Summary: En este artículo de la base de conocimientos, se explica el error de falla del expansor de SAS informado por Unity después de reemplazar un SP. (Corregible por el usuario)
Symptoms
Se reemplazó uno de los SP.
Después de reemplazar un SP, el arreglo de Unity informa que el expansor de SAS en uno de los SP tiene errores y pasa al estado degradado.
Se puede ver el siguiente mensaje de error (de Unisphere):
The SAS expander in Storage Processor SP X has faulted (Part Number 303-297-005C-05, Serial Number XXXXXXXXXXXXXX). SAS expander in the Storage Processor (SP) has faulted. Check the system logs and try rebooting the SP. If the problem persists, you may need to replace the SP.
Cause
Cuando se inserta un SP con una revisión de firmware diferente del expansor de SP, se detecta una discrepancia para la revisión del firmware del expansor de SP.
Debido a esto, Unity informa que el expansor de SAS en uno de los procesadores de almacenamiento presentó fallas.
Resolution
Después del reemplazo del SP, la revisión del firmware del expansor de SP se actualiza automáticamente dentro de unas pocas horas.
-
El error debe desaparecer después de actualizar correctamente el nuevo firmware del "expansor de SP".
Es posible que deba reiniciar los servicios de administración para borrar el error (después de unas horas de reemplazo del SP).Los pasos para reiniciar los servicios de administración se encuentran aquí: Cómo reiniciar los servicios de administración
-
Si el error persiste, comuníquese con el equipo de soporte técnico de Dell.
Additional Information
- En un caso, ambos "expansores de SP" se ejecutaban en la revisión de firmware 2.20.0
- El SP A se reemplazó a las 02:25:56 de un día determinado y se ejecutaba en la revisión de firmware "SP Expander" de 1.4.0
- Luego, Unity informó "El expansor de SAS en el SP A del procesador de almacenamiento falló" a las 02:28:11
- La actualización del firmware del "expansor de SP" en el SP A se realizó correctamente a las 04:25:30 y, después de reiniciar los servicios de administración, el error se borró.