Obnovení na úrovni souborů (FLR) systému Windows VMware selže, pokud obnovená cesta k souboru překročí omezení maximální délky cesty (MAX_PATH).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Úloha obnovení na úrovni souboru selhává v určité cestě k adresáři s hlubokou rekurzí.      Protokoly FLR zobrazují obecné protokoly chyb 

 
--------------------------------------------------------------------------------------------------------
-----  START avvmwfile log <timestamp> UTC  [18.2.100-134 Linux-x86_64]
--------------------------------------------------------------------------------------------------------

<timestamp> avvmwfile Info <5008>: Logging to /usr/local/avamarclient/var/MOD-1565970042058-<cid>-3019-vmwfilew.log
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfile.cmd
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfileAll.cmd
<timestamp> avvmwfile Info <6673>: CTL listening on port 34258
<timestamp> avvmwfile Info <10684>: Setting ctl message version to 3 (from 1)
<timestamp> avvmwfile Info <16136>: Setting ctl max message size to 268435456
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfile.cmd
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfileAll.cmd
<timestamp> avvmwfile Info <19660>: targetlist contains <dir backup="true" date="1969-01-01 00:00:00" internal="0" group="unknown" protection="drwx------" name="C:/DFS_Shares/Users/Bob" size="65536" saveas="C:/DFS_Shares/users/restore" user="unknown" />

<timestamp> avvmwfile Error <0000>: Failed to restore files via network, check proxy log for details
<timestamp>  avvmwfile Error <0000>: assist_restore error. ret: 157

--------------------------------------------------------------------------------------------------------
----- END avvmwfile log <timestamp> UTC  (0 warnings, 2 errors, 0 fatal errors)
--------------------------------------------------------------------------------------------------------

 

Cause

Uvnitř virtuálního počítače je systém Microsoft Windows nakonfigurován s distribuovaným systémem souborů DFS (Distributed File System) s velmi hlubokými strukturami stromu souborů. 

Při obnově do původního umístění se na serveru proxy zobrazí protokol skriptu FLR (/usr/local/avamarclient/bin/logs/flr*.err) následující:
 
>file name: file1.txt
>file name: files2 
>file name: <long-file>-example.txt
>fail to create file  C:\DFS_Shares\users\restore\folder1\folder2\folder3\....< file length bigger than 260 characters>-example.txt  error code:2

Problém: Bylo překročeno omezení maximální délky cesty (MAX_PATH).  Ve výchozím nastavení je tento limit 260, což způsobuje problém s vytvořením souboru obnovení, pokud kombinace umístění uložení a cesty k názvu souboru přesahuje 260 znaků


. Další informace jsou k dispozici na této stránce společnosti Microsoft: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

"V rozhraní API systému Windows (s některými výjimkami popsanými v následujících odstavcích) je maximální délka cesty MAX_PATH, což je definováno jako 260 znaků.
Místní cesta je strukturována v následujícím pořadí: písmeno jednotky, dvojtečka, zpětné lomítko, součásti názvu oddělené zpětnými lomítky a ukončující znak null

Resolution


1. V novějších operačních systémech Windows (Windows 10, verze 1607 a novější) povolte možnost Povolit dlouhé cesty.     
Následující článek znalostní databáze společnosti Microsoft obsahuje pokyny: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

NEBO

2. Místo obnovení do původního umístění proveďte přesměrované obnovení do zkrácení cesty k adresáři. 
Příklad: c:\restore\, čímž se zkrátí celková cesta k souboru.  

Affected Products

Avamar

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000053607
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.