Windows VMware File Level Restore (FLR) mislukt wanneer een hersteld bestandspad de maximale padlengtebeperking (MAX_PATH) overschrijdt

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Hersteltaak op bestandsniveau mislukt op bepaald mappad met diepe recursie.      De FLR-logboeken tonen generieke foutenlogboeken 

 
--------------------------------------------------------------------------------------------------------
-----  START avvmwfile log <timestamp> UTC  [18.2.100-134 Linux-x86_64]
--------------------------------------------------------------------------------------------------------

<timestamp> avvmwfile Info <5008>: Logging to /usr/local/avamarclient/var/MOD-1565970042058-<cid>-3019-vmwfilew.log
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfile.cmd
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfileAll.cmd
<timestamp> avvmwfile Info <6673>: CTL listening on port 34258
<timestamp> avvmwfile Info <10684>: Setting ctl message version to 3 (from 1)
<timestamp> avvmwfile Info <16136>: Setting ctl max message size to 268435456
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfile.cmd
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfileAll.cmd
<timestamp> avvmwfile Info <19660>: targetlist contains <dir backup="true" date="1969-01-01 00:00:00" internal="0" group="unknown" protection="drwx------" name="C:/DFS_Shares/Users/Bob" size="65536" saveas="C:/DFS_Shares/users/restore" user="unknown" />

<timestamp> avvmwfile Error <0000>: Failed to restore files via network, check proxy log for details
<timestamp>  avvmwfile Error <0000>: assist_restore error. ret: 157

--------------------------------------------------------------------------------------------------------
----- END avvmwfile log <timestamp> UTC  (0 warnings, 2 errors, 0 fatal errors)
--------------------------------------------------------------------------------------------------------

 

Cause

Binnen de virtuele machine is Microsoft Windows geconfigureerd met DFS (Distributed File System) met zeer diepe bestandsboomstructuren. 

Bij het herstellen naar de oorspronkelijke locatie zien we in de proxy het FLR-scriptlogboek (/usr/local/avamarclient/bin/logs/flr*.err) het volgende:
 
>file name: file1.txt
>file name: files2 
>file name: <long-file>-example.txt
>fail to create file  C:\DFS_Shares\users\restore\folder1\folder2\folder3\....< file length bigger than 260 characters>-example.txt  error code:2

Probleem: De maximale beperking van de padlengte (MAX_PATH) is overschreden.  Standaard is deze limiet 260, wat een probleem met het maken van herstelbestanden veroorzaakt als de combinatie van opslaglocatie en bestandsnaampad groter is dan 260 tekens


Meer informatie is beschikbaar op deze Microsoft-pagina: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

"In de Windows API (met enkele uitzonderingen die in de volgende paragrafen worden besproken) is de maximale lengte voor een pad MAX_PATH, wat wordt gedefinieerd als 260 tekens.
Een lokaal pad is gestructureerd in de volgende volgorde: stationsletter, dubbele punt, backslash, naamcomponenten gescheiden door backslashes en een eindigend null-teken

Resolution


1. In nieuwere Windows-besturingssystemen (Windows 10, versie 1607 en hoger) schakelt u Lange paden inschakelen in.     
De volgende Microsoft KB bevat instructies: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

OF

2. In plaats van te herstellen naar de oorspronkelijke locatie, voert u een omgeleid herstel uit naar het pad van de verkorte map. 
Voorbeeld: c:\restore\ waarmee het algehele bestandspad wordt verkleind.  

Affected Products

Avamar

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000053607
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.