База знаний по развертыванию. Прокси-сервер Datadobi DobiMigrate не имеет доступа к исходным общим и экспортируемым ресурсам

Summary: Прокси-сервер Datadobi DobiMigrate не имеет доступа к исходным общим и экспортным ресурсам.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Во время первого копирования и следующей из нескольких итераций проблем с доступом к файлам и каталогам многие из них повторяются.

Странное поведение заключается в том, что один и тот же файл может быть скопирован за одну итерацию, но следующая итерация сообщает об ошибках отказа в доступе в журналах.

Каждый раз проверяется один и тот же путь, и случайным образом файлы сообщают об отказе в доступе, и одни и те же файлы не сообщают об этом в следующих итерациях, а затем сообщают об этом.

Пример.

Для каталогов:

error: AccessDeniedException: /IT/transcore/src2/org
error: AccessDeniedException: /IT/transcore/src

После повторного переноса выполняется следующее:

DirectoryIteratorException: java.nio.file.AccessDeniedException: /IT/transcore/src2
DirectoryIteratorException: java.nio.file.AccessDeniedException: /IT/transcore/src
  • При сравнении исходного и целевого ресурсов обнаруживается, что каталог не скопирован в целевую систему.
  • Попробуйте нажать на них и выполнить принудительное копирование метаданных + данных или начать другую итерацию с метаданными повторного копирования, но это приведет к сбою
  • Если вы попытаетесь сравнить все разрешения на стороне NFS и CIFS, то увидите, что оба имеют абсолютно одинаковые разрешения: родительский каталог /IT/transcore и подкаталог IT/transcore/src2.

Для файла:

AccessDeniedException: /Marketing/fvb_test/SCR.pdf
  • При сравнении исходного и целевого файлов вы можете обнаружить, что PDF-файл скопирован, имеет одинаковое разрешение, размер и все точно такое же, за исключением владельца, который является пользователем root Linux, в то время как в исходном случае это был обычный пользователь.
  • Попробуйте открыть файл в месте назначения, он может быть поврежден и не открывается так, как исходный файл, что совершенно нормально.
  • Попытка повторно перенести метаданные, но это не сработало.
  • Однако после 2 или 3 повторных попыток обычной итерации по общему пути может оказаться, что данная ошибка для этого конкретного файла не повторяется, а в целевом дисковом массиве она открывается нормально и нормально работает.

 

Cause

Причина проблемы заключалась в том, что один из прокси-серверов NFS находился в другой сети и не мог исследовать исходные данные. У нее не было доступа.

 

Resolution

Удален экспорт NFS, который находился в другой сети и не имел доступа.

Чтобы определить, у какого прокси-сервера NFS есть или нет доступа.

Перейти в Datadobi Management UI (Core) > Tools File Browser > Выберите хранилище Выберите > прокси-сервер > Изучите файлы и убедитесь, что с помощью этого прокси-сервера можно получить доступ ко > всем файлам.

Выполните описанные выше действия, используя все прокси-серверы, чтобы определить, к какому файлу нет доступа, после чего вы сможете проверить, есть ли у прокси-серверов доступ или нет.
Файловый браузер DobiMigrate

 

Affected Products

Data Migration for Isilon with Select Software: DobiMiner and StorageX

Products

Data Migration for Isilon with Select Software: DobiMiner and StorageX
Article Properties
Article Number: 000053726
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.