Dell Unity : Erreur irrécupérable dans la session d’importation en mode bloc

Summary: Pour résoudre les problèmes liés à l’échec d’une session d’importation en mode bloc dans Unisphere, utilisez la UEMCLI afin d’afficher des informations détaillées sur la session en échec. Unisphere (UI) peut ne pas fournir suffisamment d’informations pour résoudre le problème. ...

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Symptoms

Sessions d’importation >

x  Import_FNM00104600114_migrate_xxx          Error           block


Dans l’erreur ci-dessus, le pointeur de la souris sur le X rouge permet d’afficher plus de détails :

"The import session failed due to a non-recoverable error.  Go to session properties dialog to check health details and resolution steps in GUI or use UEMCLI command  import/session/element show -detail to check session health details and resolution steps."    


La sortie UEMCLI des détails de la session affiche des messages similaires :

spa:~>uemcli /import/session show -detail
1:    ID              = import_65548
      Name            = Import_ABCD1234567890_101_20160915160406.767527+000
      Session type    = block
      Health state    = Critical failure (25)
      Health details  = "The import session failed due to a non-recoverable error. For Block import session non-recoverable error details, check session element's health details and resolution steps."
      State           = Error  ---output abridged----


Détails de la sortie UEMCLI de l’élément de session pour l’ID de session d’importation ci-dessus :

Exemple 1 :

spa:~>uemcli /import/session/element -importId import_65548 show -detail
1:    Source system   = RS_65560
      Source resource = LUN 101
      Target resource = sv_11
      Health state    = Major failure (20)
      Health details  = "Element import session related Sancopy session ran into error: 0x712A8021: The destination device could not be found. This is probably due to incorrect zoning on the switch or the device is not in the correct storage group. (WWN). This can be due to FC Zoning or iSCSI Connection configuration between VNX and Unity arrays. Please follow documentation to configure connectivity between all SP pairs between VNX and Unity system. Once FC/iSCSI connection configuration is validated, please run 'Verify and Update' operation for Remote System connection to VNX to discover/update all configuration changes. Then issue resume operation on the import session to recover session from error state."


Exemple 2 :

spb:~> uemcli /import/session/element -importId import_65600 show -detail
2:    Source system   = RS_65596
      Source resource = block_1
      Target resource = sv_79
      Health state    = Critical failure (25)
      Health details  = "The import session failed due to a non-recoverable failure. Cancel the import session and determine the integrity of the data."

Cause

A "Non-recoverable error" dans une session d’importation en mode bloc peut avoir diverses causes et peut ne pas toujours être permanente. L’examen des détails de l’élément permet d’identifier la cause première du problème. Les causes potentielles sont les suivantes :

  • Problèmes de connectivité iSCSI, qui peuvent être résolus et permettre le redémarrage de la session
  • Problèmes sur la baie VNX source, tels qu’un LUN manquant dans un groupe de cohérence, qui peuvent nécessiter l’annulation de la session
  • Indisponibilité de la LUN source en raison de la suppression ou de l’absence de mises à jour sur la baie Unity, ce qui nécessite également l’annulation de la session

L’examen des détails de l’élément peut vous aider à déterminer la cause et à prendre les mesures appropriées pour résoudre ou annuler la session en échec.

Resolution

Comme indiqué ci-dessus, il pourrait y avoir différents problèmes qui mènent à une 'Non-recoverable error' pour une session d’importation en mode bloc.
Il se peut que Unisphere (UI) ne fournisse pas suffisamment de détails pour résoudre le problème. Il est recommandé d’utiliser la sortie de l’élément de session UEMCLI afin de dépanner et de résoudre le problème.

La session d’importation a échoué avec le message « Non-recoverable error » :
1. À partir de l’interface UEMCLI, déterminez l’ID de session d’importation :

spb:~> uemcli /import/session/block show -detail
1:    ID                           = import_65600
      Name                         = Import_ABCD1234567890_migrate_20161027142745.428999+000
      Session type                 = block
      Health state                 = Critical failure (25)


2. Affichez les détails de l’élément Session d’importation pour l’ID de session d’importation :

spb:~> uemcli /import/session/element -importId import_65600 show -detail
1:    Source system   = RS_65596
      Source resource = block_1
      Target resource = sv_79
      Health state    = Critical failure (25)
      Health details  = "The import session failed due to a non-recoverable failure. Cancel the import session and determine the integrity of the data."


3. Suivez les conseils fournis dans la sortie « Détails de l’intégrité » pour dépanner et résoudre le problème de session d’importation.
Note: Pour continuer, reprenez la session sous « Plus d’actions » dans l’interface utilisateur.

Affected Products

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Hybrid
Article Properties
Article Number: 000054735
Article Type: Solution
Last Modified: 20 Nov 2025
Version:  4
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