Dell Unity: Errore irreversibile nella sessione di importazione dei blocchi

Summary: Per risolvere i problemi relativi a una sessione di importazione di blocchi non riuscita in Unisphere, utilizzare UEMCLI per visualizzare informazioni dettagliate sulla sessione non riuscita. Unisphere (UI) potrebbe non fornire informazioni sufficienti per risolvere il problema. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sessioni di importazione >

x  Import_FNM00104600114_migrate_xxx          Error           block


Passando il mouse sopra la X rossa, nell'errore precedente, vengono visualizzati ulteriori dettagli:

"The import session failed due to a non-recoverable error.  Go to session properties dialog to check health details and resolution steps in GUI or use UEMCLI command  import/session/element show -detail to check session health details and resolution steps."    


L'output UEMCLI dei dettagli della sessione mostra messaggi simili:

spa:~>uemcli /import/session show -detail
1:    ID              = import_65548
      Name            = Import_ABCD1234567890_101_20160915160406.767527+000
      Session type    = block
      Health state    = Critical failure (25)
      Health details  = "The import session failed due to a non-recoverable error. For Block import session non-recoverable error details, check session element's health details and resolution steps."
      State           = Error  ---output abridged----


L'output UEMCLI dei dettagli dell'elemento sessione per l'ID sessione di importazione di cui sopra:

Esempio 1:

spa:~>uemcli /import/session/element -importId import_65548 show -detail
1:    Source system   = RS_65560
      Source resource = LUN 101
      Target resource = sv_11
      Health state    = Major failure (20)
      Health details  = "Element import session related Sancopy session ran into error: 0x712A8021: The destination device could not be found. This is probably due to incorrect zoning on the switch or the device is not in the correct storage group. (WWN). This can be due to FC Zoning or iSCSI Connection configuration between VNX and Unity arrays. Please follow documentation to configure connectivity between all SP pairs between VNX and Unity system. Once FC/iSCSI connection configuration is validated, please run 'Verify and Update' operation for Remote System connection to VNX to discover/update all configuration changes. Then issue resume operation on the import session to recover session from error state."


Esempio 2:

spb:~> uemcli /import/session/element -importId import_65600 show -detail
2:    Source system   = RS_65596
      Source resource = block_1
      Target resource = sv_79
      Health state    = Critical failure (25)
      Health details  = "The import session failed due to a non-recoverable failure. Cancel the import session and determine the integrity of the data."

Cause

A "Non-recoverable error" in una sessione di importazione di blocchi può avere varie cause e potrebbe non essere sempre permanente. L'esame dei dettagli dell'elemento consente di identificare la root cause del problema. Ecco alcune possibili cause:

  • Problemi di connettività iSCSI, che possono essere risolti e consentire il riavvio della sessione
  • Problemi sull'array VNX di origine, ad esempio una LUN mancante in un consistency group, che potrebbero richiedere l'annullamento della sessione
  • Non disponibilità della LUN di origine a causa dell'eliminazione o della mancanza di aggiornamenti sull'array Unity, che richiede anche l'annullamento della sessione

L'analisi dei dettagli dell'elemento può aiutare a determinare la causa e intraprendere le azioni appropriate per risolvere o annullare la sessione non riuscita.

Resolution

Come descritto in precedenza, potrebbero esserci diversi problemi che portano a un 'Non-recoverable error' per una sessione di importazione di blocchi.
Unisphere (UI) potrebbe non fornire dettagli sufficienti per risolvere il problema. Si consiglia di utilizzare l'output dell'elemento sessione UEMCLI per individuare e risolvere il problema.

La sessione di importazione non è riuscita con "Errore irreversibile":
1. Da UEMCLI, determinare l'ID della sessione di importazione:

spb:~> uemcli /import/session/block show -detail
1:    ID                           = import_65600
      Name                         = Import_ABCD1234567890_migrate_20161027142745.428999+000
      Session type                 = block
      Health state                 = Critical failure (25)


2. Visualizzare i dettagli dell'elemento della sessione di importazione per l'ID sessione di importazione:

spb:~> uemcli /import/session/element -importId import_65600 show -detail
1:    Source system   = RS_65596
      Source resource = block_1
      Target resource = sv_79
      Health state    = Critical failure (25)
      Health details  = "The import session failed due to a non-recoverable failure. Cancel the import session and determine the integrity of the data."


3. Seguire i consigli forniti nell'output "Health details" per risolvere il problema della sessione di importazione.
Nota: Per procedere, riprendere la sessione in "More actions" nell'interfaccia utente.

Affected Products

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Hybrid
Article Properties
Article Number: 000054735
Article Type: Solution
Last Modified: 20 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.