Avamar : Échec de la sauvegarde avec les messages « Not enough Space » et « Mémoire insuffisante pour le fichier de cache »
Summary: La sauvegarde Avamar échoue avec les messages « Not Enough Space » et « Mémoire insuffisante pour le fichier de cache ».
Symptoms
Une sauvegarde Avamar échoue avec les messages suivants enregistrés dans le journal de sauvegarde.
AVTAR FATAL <5351>: Main: Unhandled internal exception Unix exception Not Enough Space AVTAR Debug-Error <0001> Out of Memory for cache file C:\Program Files\avs\var\p_cache.dat size 1610613280
Cause
La cause première est inconnue, mais les messages indiquent que la machine client manque d’espace.
Cela peut être dû au fait qu’il n’y a pas suffisamment d’espace disque pour l’écriture du fichier de cache. Ou cela peut être dû au fait que le client n’est pas en mesure de conserver le fichier de cache de hachage en mémoire.
Resolution
- Assurez-vous que les caches sont dimensionnés de manière appropriée pour la quantité de données sauvegardées (voir le Guide des pratiques d’excellence opérationnelles)
- Assurez-vous que le client dispose de suffisamment de mémoire pour contenir les fichiers de cache ainsi que toutes les autres applications en cours d’utilisation sur la machine
- Assurez-vous que le client dispose de suffisamment d’espace disque pour stocker le fichier de cache
Si la sauvegarde n’a jamais été effectuée auparavant, contactez votre partenaire ou les services professionnels Dell.
Additional Information
Lors d’une sauvegarde, le cache de fichiers (f_cache.dat) et le cache de hachage (p_cache.dat) sont chargés dans la mémoire.
Le client doit disposer de suffisamment de mémoire pour stocker les caches, le processus avtar et les autres processus en cours d’exécution sur la machine. Si ce n’est pas le cas, la sauvegarde échoue avec les messages signalés ci-dessus.
Les sauvegardes envoyées à Data Domain utilisent un cache de fichiers de pagination. Cela réduit la mémoire nécessaire à la conservation des entrées dans le cache de fichiers.