Avamar. Резервные копии Data Domain не реплицируются с ошибкой «у пользователя недостаточно прав доступа»

Summary: Avamar - Резервные копии Data Domain не реплицируются с ошибкой «у пользователя недостаточно прав доступа».

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Возможно, был указан клиент, что остановило бы доступ всех клиентов.

Резервные копии, сохраненные в системе Data Domain с интеграцией Avamar, не реплицируются для целей аварийного восстановления (DR).

Когда выполняется репликация, резервные копии, хранящиеся в Avamar, успешно реплицируются, но резервные копии, хранящиеся в Data Domain, завершаются сбоем, когда avtar пытается подключиться к целевому DD.

В журналах репликации, доступ к которым можно получить с консоли администрирования Avamar для каждого завершившегося сбоем задания, отображаются следующие сообщения:

avtar Warning <18125>: Calling DDR_OPEN returned result code:5075 message:the user has insufficient access rights
avtar FATAL <10608>: Replication failed: could not open connection to dest DDR <target DDR hostname>, dest LSU: avamar-xxxxxxxxxx, handle: -1, DDR result code: 5075, desc: the user has insufficient access rights. 
avtar FATAL <40009>: DDR encountered errors.

 

Cause

Список доступа DD Boost целевого DD не разрешает доступ из исходного Avamar, DD или всех клиентов.

 

Resolution

Добавьте имена хостов исходного Avamar и DD в список доступа. Затем повторно запустите репликацию, чтобы убедиться в отсутствии проблем при входе в Data Domain.

sysadmin@datadomain-dst# ddboost access show
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients show' instead.
DD Boost access allowed from the following clients:
dev-test.corp.dell.com

sysadmin@datadomain-dst# ddboost access add clients avamar-src.corp.dell.com
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients add' instead.
avamar-src.corp.dell.com : Added

sysadmin@datadomain-dst# ddboost access add clients datadomain-src.corp.dell.com
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients add' instead.
datadomain-src.corp.dell.com : Added

sysadmin@datadomain-dst# ddboost access show
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients show' instead.
DD Boost access allowed from the following clients:
dev-test.corp.dell.com
avamar-src.corp.dell.com
datadomain-src.corp.dell.com

 

Журналы репликации Avamar должны отображать следующее:

2015-06-09 14:55:08 avtar Info <40041>: - Establishing a connection to the Data Domain system with basic authentication (Connection mode: A:0 E:0).
2015-06-09 14:55:08 avtar Info <0000>: - Connected to:
Data Domain System: datadomain-src.corp.dell.com
Model:              DD4500
DDOS:               Data Domain OS 5.5.0.9-471508
Serial Number:      FXXXXXXXXXXXXX
          Capacity
Total:        140,454,501,285,888 (127.74 TB)
Available:     70,235,477,508,096 (63.879 TB)
Used:          70,219,023,777,792 (63.864 TB)
Used logical: 6,445,745,982,552,764 (5.7250 PB)
2015-06-09 14:55:08 avtar Info <0000>: Setting default storage unit to 'avamar-xxxxxxxxxx' for handle 1
2015-06-09 14:55:08 avtar Info <10543>: Data Domain login to datadomain-src.corp.dell.com successful
2015-06-09 14:55:08 avtar Info <18845>: Restore mode - No Data Domain read compression.
2015-06-09 14:55:08 avtar Info <0000>: GSAN connected via: IPv4, retrieved Data Domain IPv4 hostname = datadomain-dst.corp.dell.com
2015-06-09 14:55:08 avtar Info <10606>: Connecting to Data Domain Destination Server "datadomain-dst.corp.dell.com" (LSU: avamar-xxxxxxxxxx, User: "********")
2015-06-09 14:55:08 avtar Info <10540>: - Resolved Data Domain Server name "datadomain-dst.corp.dell.com" to the IP address "10.1.1.2"
2015-06-09 14:55:08 avtar Info <40041>: - Establishing a connection to the Data Domain system with basic authentication (Connection mode: A:0 E:0).
2015-06-09 14:55:08 avtar Info <0000>: - Connected to:
Data Domain System: datadomain-dst.corp.dell.com
Model:              DD4500
DDOS:               Data Domain OS 5.5.0.9-471508
Serial Number:      FXXXXXXXXXXXXX
          Capacity
Total:        141,259,219,402,752 (128.47 TB)
Available:    105,297,588,781,056 (95.768 TB)
Used:          35,961,630,621,696 (32.707 TB)
Used logical: 2,021,959,548,732,281 (1.7959 PB)

 

Это также можно сделать с помощью DD System Manager:

  1. Выберите Управление > данными Настройки DD Boost > .
  2. В разделе Разрешенные клиенты нажмите Создать (+).
    Откроется диалоговое окно «Добавить разрешенный клиент».
  3. Введите имя хоста клиента.
    Это может быть полностью определенное доменное имя (например, host1.dell.com) или имя хоста с подстановочными знаками (например, *.dell.com).
  4. Выберите Encryption Strength.
    Возможные значения: Нет (без шифрования), Средний (AES128-SHA1) или Высокий (AES256-SHA1).
  5. Выберите Authentication Mode.
    Возможные варианты: односторонняя, двусторонняя или анонимная.
  6. Нажмите OK.

 

Additional Information

Аналогичная ошибка может возникнуть при выполнении действий обслуживания Avamar (checkpoint, hfscheck, сборка мусора). Если какое-либо из этих действий завершается сбоем MSG_ERR_DDR_ERROR, а в журнале ddrmaint отображается сообщение «у пользователя недостаточно прав». Интеграция Avamar-Data Domain. Сбои обслуживания из-за неверного владельца MTree Avamar в системе Data Domain

 

Другие причины включают неверный пароль или истечение времени ожидания пароля. В следующих статьях базы знаний содержится дополнительная информация:
Avamar — Не удалось обновить систему Data Domain или подключиться к ней из-за блокировки пользователя DDBoost.
Пользовательский интерфейс администратора Avamar сообщает о неверном состоянии Data Domain из-за истечения срока действия пароля ddboost.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000055013
Article Type: Solution
Last Modified: 16 Jul 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.