AppSync: Nepodařilo se zakázat vyvažování ASM na hostiteli.

Summary: AppSync: Nepodařilo se zakázat vyvažování ASM na hostiteli.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Po rozšíření prostoru nebo zvětšení dostupného místa ve skupině disků přidáním zařízení do skupiny disků ASM v systému Oracle proběhne v Oracle proces vyvážení ASM.

Pokud doba potřebná k obnovení rovnováhy v aplikaci Oracle překročí časový limit AppSync SFTP, zobrazí se v událostech servisního plánu následující chyba:
 

Nepodařilo se zakázat vyrovnávání ASM na hostiteli: ip-10-xxx-xxx-xxx.env. Funkce Copy nemusí být konzistentní s
aplikací. Při komunikaci se zásuvným modulem hostitele AppSync došlo k chybě. Zkontrolujte, zda je spuštěna služba agenta, a v případě potřeby jej restartujte.


Protokol serveru:

 
 CHYBA DATA><A ČASU>[Thread-336979 (HornetQ-client-global-threads-2040611065)]
[com.emc.archway.service.sshservice.SecureShellSession] [] [] Chyba při získávání souboru přes SFTP: session is down
DATUM><A ČAS>ERROR [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.sshservice.SecureShellSession] [] [] Chyba při získávání souboru přes SFTP: Žádný takový soubor
DATUM><A ČAS>ERROR INFO [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.sshservice.SshServiceBean] [] [] Opakování pokusu o získání souboru. 0f6bc923-7c8c-474d-bb38-ac531ba21xxx.rsp

DATUM><A ČAS>ERROR INFO [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.eventservice.EventServiceBean] [] [] UDÁLOST [GENL_000023]: Při komunikaci se zásuvným modulem AppSync Host došlo k chybě.  Zkontrolujte, zda je spuštěna služba agenta, a v případě potřeby počítač restartujte. (METADATA: TYPE-ERROR, TIME-2016-12-20 00:40:05.474+0100NATIVETIME-2016-12-20 00:40:05.474+0100, HOST-sa5emp01, PHASE-Create local copy, THREAD=Thread-336979 (HornetQ-client-global-threads-2040611065), USER-null, CATEGORY-GENERIC, SESSIONID-null)
DATUM><A ČAS>ERROR INFO [Thread-337534 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.commands.event.ArchwayEventListenerHelperCommandBean] [] [] Přijatý posluchač události: GENL_000023
CHYBA DATA><A ČASU>ERROR [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.commands.application.oracle.QuiesceOracleCommandBean] [] [] Nepodařilo se odstranit vyvážení ASM na hostiteli: ip-10-237-0-xxx.env. Kopírování nemusí být konzistentní. 

 


 

Cause

Příčinou tohoto problému u verzí AppSync starších než 3.0.2 je to, že doba potřebná k provedení vyvážení v systému Oracle překročila výchozí časový limit AppSync SFTP a AppSync se nepokusí zastavit vyvážení před pořízením kopie.

Resolution

Do softwaru AppSync 3.0.2 byla přidána nová funkce, která před pořízením snímku nebo klonu podkladových disků vypne vyrovnávání ASM a po vytvoření kopie jej znovu zapne.
Tento problém vyřešíte upgradem na AppSync verze 3.0.2 nebo vyšší.

Je stále možné, že časový limit AppSync SFTP bude překročen, pokud k zastavení nebo restartování vyvážení ASM nedojde rychle. V takových případech může být nutné prodloužit časový limit SFTP, což může provést zákaznická podpora. Výchozí časový limit SFTP je 3 600 sekund.
Pokud si myslíte, že je třeba prodloužit časový limit SFTP, zavolejte požadavek na servis a uveďte tento článek.



 

Additional Information

Je důležité vědět, proč vyvažování probíhá. K opětovnému vyvážení může dojít z různých důvodů: pokud dojde k selhání disku, databáze není synchronizovaná nebo není k dispozici žádné místo.

Pokud k vyvážení nedochází z důvodu přidání disku do dostupné skupiny disků, nelze na tento článek odkazovat, a proto může dojít k zablokování databáze nebo jednotky DU a zákazník musí zapojit tým DBA, aby problém napravil.

Další informace o přidání a správě skupiny disků ASM a rebalancování naleznete v https://docs.oracle.com/cd/B28359_01/server.111/b31107/asmdiskgrps.htm#OSTMG10040.

Pokud po přidání zařízení do skupiny disků ASM dojde k zablokování, přečtěte si článek 000359509.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000055068
Article Type: Solution
Last Modified: 04 Aug 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.