AppSync: Deaktiver ikke ASM-justering på værten
Summary: AppSync: Deaktiver ikke ASM-rebalancering på værten.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Når du har udvidet pladsen eller øget den tilgængelige diskgruppeplads ved at føje enheder til en ASM-diskgruppe i Oracle, er der en proces med ASM-rebalancering i Oracle.
Hvis den tid, det tager Oracle at genoprette balancen, overstiger AppSync SFTP-timeoutperioden, vises følgende fejl i serviceplanhændelserne:
Kunne ikke deaktivere ASM-rebalancering på vært: ip-10-xxx-xxx-xxx.env. Kopieringen er muligvis ikke programkonsistent
Der opstod en fejl under kommunikation med AppSync-værts-plug-in'en. Kontroller, om agenttjenesten kører, og genstart om nødvendigt.
Der opstod en fejl under kommunikation med AppSync-værts-plug-in'en. Kontroller, om agenttjenesten kører, og genstart om nødvendigt.
Serverlog:
DATO><KLOKKESLÆT>FEJL [Thread-336979 (HornetQ-client-global-threads-2040611065)]
[com.emc.archway.service.sshservice.SecureShellSession] [] [] Fejl under hentning af fil via SFTP: sessionen er nede
DATO><KLOKKESLÆT>FEJL [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.sshservice.SecureShellSession] [] [] Fejl under hentning af fil over SFTP: Ingen sådan fil
DATO><KLOKKESLÆT>FEJL INFO [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.sshservice.SshServiceBean] [] [] [] Forsøger at hente filen igen.. 0f6bc923-7c8c-474d-bb38-ac531ba21xxx.rsp
DATO><KLOKKESLÆT>FEJL INFO [Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.eventservice.EventServiceBean] [] [] BEGIVENHED [GENL_000023]: Der opstod en fejl under kommunikation med AppSync-værts-plug-in'en. Kontroller, om agenttjenesten kører, og genstart om nødvendigt. (METADATA: TYPEFEJL, TID-2016-12-20 00:40:05.474+0100NATIVETIME-2016-12-20 00:40:05.474+0100, HOST-sa5emp01, PHASE-Create local copy, THREAD=Thread-336979 (HornetQ-client-global-threads-2040611065), USER-null, CATEGORY-GENERIC, SESSIONID-null)
OPLYSNINGER OM DATO></KLOKKESLÆT-FEJL>[Thread-337534 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.commands.event.ArchwayEventListenerHelperCommandBean] [] [] Hændelseslytteren modtog: GENL_000023
FEJL VED DATO></KLOKKESLÆT>[Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.commands.application.oracle.QuiesceOracleCommandBean] [] [] Kunne ikke deaktivere ASM-rebalancering på vært: ip-10-237-0-xxx.env. Kopiering er muligvis ikke ensartet.
Cause
Årsagen til dette problem for versioner af AppSync før 3.0.2 er, at den tid, det tog for Oracle at udføre rebalance, overskred standardtimeoutperioden for AppSync SFTP, og AppSync vil ikke forsøge at stoppe genbalancen, før der tages en kopi.
Resolution
Der føjes en ny funktion til AppSync 3.0.2, som deaktiverer ASM-rebalancering, før der tages et snapshot eller en klon af de underliggende diske, og slår den til igen, når kopien er oprettet.
Opgrader til AppSync version 3.0.2 eller nyere for at løse dette problem.
Det er stadig muligt, at AppSync SFTP-timeouten overskrides, hvis standsning eller genstart af ASM-rebalanceringen ikke sker hurtigt. I sådanne tilfælde kan det være nødvendigt at øge SFTP-timeouten, hvilket kan gøres af kundesupport. Standard SFTP-timeout er 3600 sekunder.
Indkald en serviceanmodning, og citer denne artikel, hvis du føler, at SFTP-timeouten skal øges.
Opgrader til AppSync version 3.0.2 eller nyere for at løse dette problem.
Det er stadig muligt, at AppSync SFTP-timeouten overskrides, hvis standsning eller genstart af ASM-rebalanceringen ikke sker hurtigt. I sådanne tilfælde kan det være nødvendigt at øge SFTP-timeouten, hvilket kan gøres af kundesupport. Standard SFTP-timeout er 3600 sekunder.
Indkald en serviceanmodning, og citer denne artikel, hvis du føler, at SFTP-timeouten skal øges.
Additional Information
Det er vigtigt at vide, hvorfor rebalanceringen kører. Genbalancering kan ske af forskellige årsager: Hvis der er fejl på disken, er databasen ude af synkronisering eller ingen ledig plads.
Hvis rebalanceringen ikke sker på grund af tilføjelse af disk til tilgængelig diskgruppe, kan der ikke henvises til denne artikel, derfor kan der muligvis hænge i databasen eller DU, og kunden skal engagere DBA-teamet for at rette det.
Se https://docs.oracle.com/cd/B28359_01/server.111/b31107/asmdiskgrps.htm#OSTMG10040 for at få flere oplysninger om tilføjelse og administration af ASM-diskgruppe og rebalancering.
Hvis der opstår en fejl, efter at du har føjet enheder til ASM-diskgruppen, kan du se artiklen 000359509.
Hvis rebalanceringen ikke sker på grund af tilføjelse af disk til tilgængelig diskgruppe, kan der ikke henvises til denne artikel, derfor kan der muligvis hænge i databasen eller DU, og kunden skal engagere DBA-teamet for at rette det.
Se https://docs.oracle.com/cd/B28359_01/server.111/b31107/asmdiskgrps.htm#OSTMG10040 for at få flere oplysninger om tilføjelse og administration af ASM-diskgruppe og rebalancering.
Hvis der opstår en fejl, efter at du har føjet enheder til ASM-diskgruppen, kan du se artiklen 000359509.
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000055068
Article Type: Solution
Last Modified: 04 Aug 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.