AppSync: impossibile disabilitare il ribilanciamento ASM sull host
Summary: AppSync: impossibile disabilitare il ribilanciamento ASM sull host.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Dopo aver ampliato lo spazio o aumentato lo spazio del gruppo di dischi disponibile aggiungendo dispositivi a un gruppo di dischi ASM in Oracle, è in corso un processo di ribilanciamento ASM in Oracle.
Se il tempo necessario a Oracle per ribilanciare supera il periodo di timeout SFTP di AppSync, verrà visualizzato il seguente errore negli eventi del piano di assistenza:
Impossibile disabilitare il ribilanciamento ASM sull host: ip-10-xxx-xxx-xxx.env. La copia potrebbe non essere coerente
con l'applicazione Si è verificato un errore durante la comunicazione con il plug-in host AppSync. Verificare se il servizio dell'agent è in esecuzione e, se necessario, riavviarlo.
con l'applicazione Si è verificato un errore durante la comunicazione con il plug-in host AppSync. Verificare se il servizio dell'agent è in esecuzione e, se necessario, riavviarlo.
Registro del server:
ERRORE DATA><E ORA>[Thread-336979 (HornetQ-client-global-threads-2040611065)]
[com.emc.archway.service.sshservice.SecureShellSession] [] [] Errore durante il caricamento del file su SFTP: la sessione è inattiva
ERRORE DATA><E ORA>[Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.sshservice.SecureShellSession] [] [] Errore durante il caricamento del file su SFTP: Nessun file di questo tipo
INFORMAZIONI ERRORE DATA><ORA>[Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.sshservice.SshServiceBean] [] [] Nuovo tentativo di ottenere il file.. 0f6bc923-7c8c-474d-bb38-ac531ba21xxx.rsp
INFORMAZIONI SULL'ERRORE DATA><E ORA>[Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.service.eventservice.EventServiceBean] [] [] EVENTO [GENL_000023]: Si è verificato un errore durante la comunicazione con il plug-in host AppSync. Verificare se il servizio agent è in esecuzione e, se necessario, riavviarlo. (METADATI: ERRORE TIPO, ORA-2016-12-20 00:40:05.474+0100NATIVETIME-2016-12-20 00:40:05.474+0100, HOST-sa5emp01, FASE-Crea copia locale, THREAD=Thread-336979 (HornetQ-client-global-threads-2040611065), USER-null, CATEGORY-GENERIC, SESSIONID-null)
INFORMAZIONI SULL'ERRORE DATA><E ORA>[Thread-337534 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.commands.event.ArchwayEventListenerHelperCommandBean] [] [] Listener di eventi ricevuto: GENL_000023
ERRORE ERRORE DATA><ORA>[Thread-336979 (HornetQ-client-global-threads-2040611065)] [com.emc.archway.commands.application.oracle.QuiesceOracleCommandBean] [] [] Impossibile disabilitare il ribilanciamento ASM sull host: ip-10-237-0-xxx.env. La copia potrebbe non essere coerente.
Cause
La causa di questo problema per le versioni di AppSync precedenti alla 3.0.2 è dovuta al fatto che il tempo impiegato da Oracle per eseguire il ribilanciamento ha superato il periodo di timeout SFTP predefinito di AppSync e AppSync non tenterà di arrestare il ribilanciamento prima di acquisire una copia.
Resolution
In AppSync 3.0.2 è stata aggiunta una nuova funzione che disattiva il ribilanciamento ASM prima di acquisire un'istantanea o un clone dei dischi sottostanti e lo riattiva dopo la creazione della copia.
Per risolvere il problema, eseguire l'aggiornamento ad AppSync versione 3.0.2 o successiva.
È comunque possibile che il timeout SFTP di AppSync venga superato nel caso in cui l'arresto o il riavvio del ribilanciamento ASM non avvenga rapidamente. In questi casi, potrebbe essere necessario aumentare il timeout SFTP, operazione che può essere eseguita dall'assistenza clienti. Il timeout SFTP predefinito è 3.600 secondi.
Se ritieni necessario aumentare il timeout SFTP, invia una Service Request e cita questo articolo.
Per risolvere il problema, eseguire l'aggiornamento ad AppSync versione 3.0.2 o successiva.
È comunque possibile che il timeout SFTP di AppSync venga superato nel caso in cui l'arresto o il riavvio del ribilanciamento ASM non avvenga rapidamente. In questi casi, potrebbe essere necessario aumentare il timeout SFTP, operazione che può essere eseguita dall'assistenza clienti. Il timeout SFTP predefinito è 3.600 secondi.
Se ritieni necessario aumentare il timeout SFTP, invia una Service Request e cita questo articolo.
Additional Information
È importante sapere perché il ribilanciamento è in esecuzione. Il ribilanciamento può verificarsi per diversi motivi: se si verifica un errore nel disco, il database non è sincronizzato o non c'è spazio disponibile.
Se il ribilanciamento non è dovuto all'aggiunta di un disco al gruppo di dischi disponibile, non è possibile fare riferimento a questo articolo, pertanto potrebbe esserci un possibile blocco della non disponibilità dei dati e il cliente dovrà contattare il team DBA per risolvere il problema.
Fare riferimento https://docs.oracle.com/cd/B28359_01/server.111/b31107/asmdiskgrps.htm#OSTMG10040 per ulteriori informazioni sull'aggiunta e la gestione del gruppo di dischi ASM e sul ribilanciamento.
Se si verifica un blocco dopo l'aggiunta di dispositivi al gruppo di dischi ASM, consultare l'articolo 000359509.
Se il ribilanciamento non è dovuto all'aggiunta di un disco al gruppo di dischi disponibile, non è possibile fare riferimento a questo articolo, pertanto potrebbe esserci un possibile blocco della non disponibilità dei dati e il cliente dovrà contattare il team DBA per risolvere il problema.
Fare riferimento https://docs.oracle.com/cd/B28359_01/server.111/b31107/asmdiskgrps.htm#OSTMG10040 per ulteriori informazioni sull'aggiunta e la gestione del gruppo di dischi ASM e sul ribilanciamento.
Se si verifica un blocco dopo l'aggiunta di dispositivi al gruppo di dischi ASM, consultare l'articolo 000359509.
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000055068
Article Type: Solution
Last Modified: 04 Aug 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.