Avamar: Hyper-V Backups Failing to Start or with Message "Maximum buffer size exceeded in ustring"
Summary: Avamar Hyper-V Resilient Change Tracking (RCT) backups failing to start or receiving message "Maximum buffer size exceeded in ustring."
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Symptoms
Hyper-V RCT incremental backups run for many hours (stop responding) and may fail with the following messages (after enabling debugging in either dataset or avhypervvss.cmd file):
[hypervvss_assist] WARN: <1104> Maximum buffer size exceeded in ustring::sprintfva() ... avhypervvss Error <19328>: [EMC-DELL-01] is unable to forward CTL sub-workorder to remote client [EMC-DELL-01]. avhypervvss Error <19366>: Unable to send sub-workorders to all remote clients avhypervvss Error <41659>: Backup did not complete successfullyHowever Avamar Hyper-V RCT backups with Backup Level option in dataset set to "Full" completes as expected.
Cause
Code issue in the Avamar Hyper-V Volume Shadow Copy Service (VSS) plug-in.
The issue is that the work-order data (in string) is more than what an XML message can contain. When the plug-in creates a work-order XML message from the data, it is truncating the data casing failure of backup.
The issue is that the work-order data (in string) is more than what an XML message can contain. When the plug-in creates a work-order XML message from the data, it is truncating the data casing failure of backup.
Resolution
To address this issue:
- Upgrade the Avamar Server to 19.4.100-124 or later.
- The fix is in Avamar 19.4 and later software releases.
--request-ctl-timeout=600000
Affected Products
Avamar Plug-in for Hyper-V VSSArticle Properties
Article Number: 000055431
Article Type: Solution
Last Modified: 12 Jun 2024
Version: 6
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