Avamar: SQL plugin – druhá přírůstková záloha je bez platného důvodu povýšena na FULL

Summary: Zálohy Avamar SQL – druhá přírůstková záloha je bez platného důvodu povýšena na FULL.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Po dokončení úplných záloh SQL se zálohování databází zobrazí v režimu FULL.

 

První přírůstková záloha se dokončí bez problémů a vytvoří se přírůstková záloha.

2018-11-28 14:39:05 avsql Info <40401>: Only the LSN was verified, during log gap detection.

2018-11-28 14:39:05 avsql Info <14293>: Creating a database task for '(local)/DB/i-1.DB' (hcount 427)

 

Druhý přírůstkový soubor však selže s chybami mezery v protokolu a je povýšen na hodnotu FULL.

2018-11-28 14:35:16 avsql Info <15765>: A log gap was identified or a full backup was not found.

2018-11-28 14:35:16 avsql Warning <7420>: Forcing FULL backup for database '(local)/DB' due to the following reason: A log gap was identified or a full backup was not found.

 

V tomto případě existuje nedávná úplná záloha a žádný jiný zálohovací nástroj mezi nimi nespouštěl přírůstkové zálohy, které by mohly poškodit pořadové číslo protokolu (LSN) a odůvodnit "detekci mezery v protokolu", proto má tato operace "Povýšeno na FULL" neplatný důvod.

 

Cause

Algoritmus Avamar pro získání informací o posledním pořadovém čísle protokolu (LSN) byl upraven z verze 7.4 na 7.5. kód, který způsobil tento problém.

 

Technický tým tento problém napravil poskytnutím opravy hotfix, která obsahuje změnu v dotazu na načtení posledního LSN databází.

 

Resolution

Chcete-li vyřešit selhání doplňku Avamar SQL, když je druhá přírůstková záloha neočekávaně "povýšena na FULL", použijte následující HF nebo upgradujte klienta Avamar na novější verzi softwaru, pokud je vhodnější:

v19.4.100-124    - HF#335861
v19.7.100-82     - HF#336118
v19.8 and above  - Fix already included into the code.

 

Stáhněte si HF podle tohoto článku znalostní databáze a před použitím si nezapomeňte přečíst pokyny k souboru README:

  • KB 000212375 – Avamar: Jak najít a stáhnout balíček s opravou hotfix, záplatou, instalací nebo upgradem produktu z webu podpory společnosti Dell

 

Additional Information

  • Ujistěte se, že ovlivněné databáze SQL nejsou nedávno obnovené databáze.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000055465
Article Type: Solution
Last Modified: 11 Jun 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.