Avamar: Wtyczka SQL — druga przyrostowa kopia zapasowa jest promowana do FULL bez ważnego powodu
Summary: Kopie zapasowe Avamar SQL — druga przyrostowa kopia zapasowa jest promowana do PEŁNEJ bez ważnego powodu.
Symptoms
Po zakończeniu tworzenia pełnych kopii zapasowych baz danych widzimy, że kopia zapasowa baz danych jest wyświetlana w trybie PEŁNYM.
Pierwsza przyrostowa kopia zapasowa zostanie wykonana bez żadnych problemów i widzimy, że zostanie utworzona dodatkowa kopia zapasowa.
2018-11-28 14:39:05 avsql Info <40401>: Only the LSN was verified, during log gap detection. 2018-11-28 14:39:05 avsql Info <14293>: Creating a database task for '(local)/DB/i-1.DB' (hcount 427)
Jednak drugi przyrost kończy się niepowodzeniem z błędami luki w dzienniku i zostaje podniesiony do poziomu FULL.
2018-11-28 14:35:16 avsql Info <15765>: A log gap was identified or a full backup was not found. 2018-11-28 14:35:16 avsql Warning <7420>: Forcing FULL backup for database '(local)/DB' due to the following reason: A log gap was identified or a full backup was not found.
W takim przypadku istnieje ostatnia pełna kopia zapasowa i żadne inne narzędzie do tworzenia kopii zapasowych nie uruchamiało pomiędzy nimi przyrostowych kopii zapasowych, które mogłyby złamać LSN (numer sekwencyjny dziennika) i uzasadnić "wykrycie luki w dzienniku", dlatego ta operacja "Awans do FULL" ma nieprawidłowy powód.
Cause
Algorytm Avamar uzyskujący ostatnie informacje o numerze sekwencji dziennika (LSN) został zmodyfikowany z 7.4 na 7.5. kodu, który spowodował ten problem.
Zespół inżynierów rozwiązał ten problem, udostępniając poprawkę zawierającą zmianę w zapytaniu pobierania ostatniej nazwy LSN baz danych.
Resolution
Aby rozwiązać problemy z wtyczkami Avamar SQL, gdy druga przyrostowa kopia zapasowa jest nieoczekiwanie "promowana do PEŁNEJ", zastosuj następujące HF lub uaktualnij klienta Avamar do nowszej wersji oprogramowania, jeśli odpowiada to bardziej szczegółowo:
v19.4.100-124 - HF#335861 v19.7.100-82 - HF#336118 v19.8 and above - Fix already included into the code.
Postępuj zgodnie z tym artykułem bazy wiedzy, aby pobrać HF i pamiętaj, aby przeczytać instrukcje dotyczące pliku README przed jego zastosowaniem:
- Bazy wiedzy 000212375 — Avamar: Jak znaleźć i pobrać pakiet poprawek, poprawek, instalacji lub uaktualnień produktu z witryny pomocy technicznej firmy Dell
Additional Information
- Upewnij się, że bazy danych SQL, których dotyczy problem, nie są ostatnio przywróconymi bazami danych.