Isilon HDFS: "STATUS_IO_TIMEOUT" beim Ausführen des "HDFS ls"-Vorgangs auf dem Compute-Node
Summary: Der Vorgang "hdfs ls" von einem Compute-Node auf dem Isilon-Dateisystem schlägt möglicherweise zeitweise mit dem Fehler "ls: Fehler beim Erstellen des Sicherheitskontexts für den Nutzer oozie Ursache: STATUS_IO_TIMEOUT: Status: STATUS_IO_TIMEOUT = 0xC00000B5" ...
Symptoms
Bei der Durchführung eines "hdfs ls"-Vorgangs von einem Rechner-Node auf dem Isilon-Dateisystem schlagen verschiedene Nutzer zeitweise mit dem folgenden Fehler fehl:
[oozie@hdp ~]$ hdfs dfs -ls /
ls: Fehler beim Erstellen des Sicherheitskontexts für den Nutzer oozie Ursache: STATUS_IO_TIMEOUT: Status: STATUS_IO_TIMEOUT = 0xC00000B5
Es werden zugehörige Fehler auf Isilon hdfs angezeigt. Protokoll für denselben Vorgang:
java.io.IOException-Ursache: Fehler beim Erstellen des Sicherheitskontexts für Nutzer <xxxx/yyyy@zzz.com> Ursache: STATUS_IO_TIMEOUT: Status: STATUS_IO_TIMEOUT = 0xC00000B5
Cause
Dies kann zwei Gründe haben:
1) Ein fehlerhafter DNS-Eintrag auf dem Isilon. Wir können den Namen der Smartconnect-Zone nicht mit "nslookup" und "dig" für diese verknüpften Gruppennetz-DNS-Server abfragen.
1. So listen Sie die DNS-Server auf, die in der Isilon:
# isi-Netzwerkgruppennetzliste
konfiguriert sind 2. Um zu überprüfen, ob der konfigurierte FQDN auf dem HDFS-Server mit den DNS-Servern auf dem Isilon:
# nslookup <FQDN-DNS-Server><> abgefragt werden kann
# dig @<dns-Server-IP-FQDN><>
2) Probleme mit der Domain-Konnektivität zwischen Isilon und der zugehörigen Domain, die in der Zugriffszone verwendet wird. Sowohl primäre als auch vertrauenswürdige Domains müssen problemlos mit Isilon kommunizieren können. Sie können nach Domänen suchen, die nicht aufgelöst werden können, indem Sie sich die Nachrichten in /var/log/lsassd.log ansehen.
Resolution
# isi network groupnets modify <groupnet ID> --remove-dns-servers=<Fehlerhafte DNS-Server-IP
>
Wenn die primäre oder eine der zugehörigen vertrauenswürdigen Domains nicht erreichbar oder offline ist, müssen wir ein weiteres Troubleshooting durchführen, um das zugrunde liegende
Problem zu beheben.
Das Problembehandlungshandbuch für die Offlinedomäne ist ein guter Ausgangspunkt: http://www.emc.com/collateral/TechnicalDocument/docu63151.pdf