Isilon HDFS : « STATUS_IO_TIMEOUT » lors de l’exécution de l’opération « hdfs ls » sur le nœud de calcul
Summary: L’opération « hdfs ls » à partir d’un nœud de calcul sur le système de fichiers Isilon peut échouer par intermittence avec l’erreur « ls : Error creating security context for user oozie cause : STATUS_IO_TIMEOUT : status : STATUS_IO_TIMEOUT = 0xC00000B5" ...
Symptoms
Lors de l’exécution d’une opération « hdfs ls » à partir d’un nœud de calcul sur le système de fichiers Isilon, différents utilisateurs échouent par intermittence avec l’erreur suivante :
[oozie@hdp ~]$ hdfs dfs -ls /
ls : Error creating security context for user oozie cause : STATUS_IO_TIMEOUT : status : STATUS_IO_TIMEOUT = 0xC00000B5
Vous verrez des erreurs connexes sur Isilon hdfs,log pour la même opération :
java.io.IOException cause : Erreur lors de la création du contexte de sécurité pour l’utilisateur <xxxx/yyyy@zzz.com> cause : STATUS_IO_TIMEOUT : status : STATUS_IO_TIMEOUT = 0xC00000B5
Cause
Cela peut être dû à deux raisons :
1) Une entrée DNS défectueuse sur l’Isilon. Nous ne serons pas en mesure d’interroger le nom de la zone SmartConnect sur ces serveurs DNS de réseau de groupe associés à l’aide des commandes « nslookup » et « dig ».
1. Pour répertorier les serveurs DNS configurés sur la liste
Isilon :
# isi network groupnets2. Pour vérifier si nous sommes en mesure d’interroger le FQDN configuré sur le serveur HDFS avec les serveurs DNS présents sur le serveur DNS Isilon :
# nslookup <FQDN><DNS server>
# dig @<dns server IP><FQDN>
2) Problèmes de connectivité de domaine entre Isilon et le domaine associé utilisé dans la zone d’accès. Les domaines principal et de confiance doivent être en mesure de communiquer avec Isilon sans aucun problème. Vous pouvez vérifier s’il y a des domaines qui ne peuvent pas être résolus en examinant les messages dans /var/log/lsassd.log,
Resolution
# isi network groupnets modify <groupnet ID> --remove-dns-servers=<Faulty DNS server IP>
Si le domaine principal ou l’un des domaines de confiance associés ne sont pas accessibles ou sont hors ligne, nous devons poursuivre le dépannage pour creuser le problème sous-jacent.
Le guide de dépannage du domaine hors ligne est un bon point de départ : http://www.emc.com/collateral/TechnicalDocument/docu63151.pdf