Isilon HDFS: "STATUS_IO_TIMEOUT" durante l'esecuzione dell'operazione "HDFS LS" sul nodo di elaborazione
Summary: L'operazione "hdfs ls" da un nodo di elaborazione sul file system Isilon potrebbe non riuscire in modo intermittente con errore "ls: Errore durante la creazione del contesto di sicurezza per la causa dell'oozie dell'utente: STATUS_IO_TIMEOUT: stato: STATUS_IO_TIMEOUT = 0xC00000B5" ...
Symptoms
Quando si esegue un'operazione "hdfs ls" da un nodo di elaborazione sul file system Isilon, utenti diversi avranno esito negativo in modo intermittente con il seguente errore:
[oozie@hdp ~]$ hdfs dfs -ls /
ls: Errore durante la creazione del contesto di sicurezza per la causa dell'oozie dell'utente: STATUS_IO_TIMEOUT: stato: STATUS_IO_TIMEOUT = 0xC00000B5
Verranno visualizzati gli errori correlati su Isilon hdfs,log per la stessa operazione:
java.io.IOException cause: Errore durante la creazione del contesto di sicurezza per l'utente <xxxx/yyyy@zzz.com> causa: STATUS_IO_TIMEOUT: stato: STATUS_IO_TIMEOUT = 0xC00000B5
Cause
Ciò può essere dovuto a due motivi:
1) Una voce DNS errata su Isilon. Non sarà possibile eseguire una query sul nome della zona SmartConnect con questi server DNS groupnet associati utilizzando "nslookup" e "dig".
1. Per elencare i server DNS configurati nell'elenco
Isilon:
# isi network groupnets2. Per verificare se è possibile eseguire una query sull'FQDN configurato sul server HDFS con i server DNS presenti sul server> DNS dell'FQDN Isilon:# nslookup <FQDN><
# dig @<dns server IP><FQDN>
2) Problemi di connettività del dominio tra Isilon e il dominio associato utilizzato nella zona di accesso. Entrambi i domini primari e affidabili devono essere in grado di comunicare con Isilon senza problemi. È possibile verificare la presenza di eventuali domini che non possono essere risolti esaminando i messaggi in /var/log/lsassd.log,
Resolution
# isi network groupnets modify <groupnet ID> --remove-dns-servers=<IP
>server DNS difettoso Se il dominio primario o uno qualsiasi dei domini attendibili associati non è raggiungibile o in stato offline, è necessario approfondire ulteriormente la risoluzione dei problemi per individuare il problema sottostante.
La guida alla risoluzione dei problemi per il dominio offline è un buon punto di partenza: http://www.emc.com/collateral/TechnicalDocument/docu63151.pdf