Dell EMC Unity : L’administrateur de stockage ne peut pas se connecter à l’interface de gestion Unity à l’aide de SSH avec un fichier de clé publique (corrigible par Dell EMC)

Summary: L’administrateur de stockage ne peut pas se connecter à l’interface de gestion Unity à l’aide de SSH avec un fichier de clé publique.

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Symptoms

  1. Le système Unity a été mis à niveau de OE 4.5 vers 5.0.
  2. En raison de la politique de sécurité, seul HMAC SHA2 est autorisé côté client Linux.
L’administrateur de stockage a configuré une connexion SSH sans mot de passe (connexion de fichier de clé publique SSH) à partir de son client Linux (RHEL7) vers l’interface de gestion Unity, qui fonctionnait bien auparavant. Après la mise à niveau de Unity d’OE 4.5 vers 5.0, cela ne fonctionne pas.

Cause

  1. L’ACL supplémentaire qui a été ajoutée dans la version 5.0 à /cores/service dans le cadre de la modification de l’utilisateur sous lequel le service ECOM s’exécute, est la cause de ce problème. Dans la version 4.5, ECOM s’exécutait en tant qu’utilisateur root et dans la version 5.0, il a été remplacé par un nouvel utilisateur ECOM. Des ACL ont été ajoutées pour l’ECOM utilisateur à /cores/service. Cette ACL supplémentaire entraîne l’échec de la connexion sans mot de passe de SSH.
  2. Ce problème est dû au fait que Unity n’active pas hmac-sha2 par défaut. Unity limitera SSH aux HMAC SHA2 uniquement dans la prochaine version (5.1).

Resolution

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Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
Article Properties
Article Number: 000055630
Article Type: Solution
Last Modified: 02 Dec 2021
Version:  4
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