Connectrix Brocade: "Prozessor neu gestartet – Softwarefehler: ASSERT"
Summary: In diesem Artikel wird die Problemumgehung erläutert, wenn der Switch aufgrund des Fehlers "Prozessor neu gestartet – Softwarefehler: ASSERT" neu gestartet wurde.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Der Switch wurde aufgrund des folgenden Fehlers neu gestartet:
Processor rebooted - Software Fault:ASSERT
Cause
Der "Softwarefehler:ASSERT" ist ein Softwareproblem und trat auf CP1 auf (früher aktiv) auf, es wurde auf den anderen CP0 (früherer Standby)
umgeschaltet. Das Problem lag in den Routing-Diensten, ein Nullzeiger wurde empfangen, während versucht wurde, die Daten abzurufen.
umgeschaltet. Das Problem lag in den Routing-Diensten, ein Nullzeiger wurde empfangen, während versucht wurde, die Daten abzurufen.
Nach dem Failover:
Fabric OS: v7.1.1c1 hadump : --------------------------------------- TIME_STAMP: Mar 7 11:23:37.498073 --------------------------------------- Local CP (Slot 6, CP0): Active, Cold Recovered Remote CP (Slot 7, CP1): Standby, Healthy HA enabled, Heartbeat Up, HA State synchronized errdump: 2019/03/04-00:22:05, [HAM-1004], 30432, SLOT 7 | CHASSIS, INFO, ED_DCX8510_8B, Processor rebooted - Software Fault:ASSERT. Core.pd file: MSR: 00029200 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 0/0 TASK = b06c8e10[1869] 'RTEK_TH' Last syscall: -1 ASSERT - Failed expression: op != NULL, file = /vobs/projects/springboard/build/swbd62/fabos/src/sys/lib/fabos/fabobj_mgr/fabmedia.c, line = 183, kernel mode args = 0 set_reboot_reason reason=Software Fault:ASSERT Kernel panic - not syncing: fabos assertion failed cpu 0: ASSERT - Failed expression: op != NULL, file = /vobs/projects/springboard/build/swbd62/fabos/src/sys/lib/fabos/fabobj_mgr/fabmedia.c, line = 183 args = 0 PD Start PowerPC Book-E Watchdog Shutdown soft timer PLATFORM_FIRST MTRACER mtracer_panicdump mtracer_panicdump write=0x44a1 reboot_reason PD_MISC CONSOLE_LOG 6300 KBytes in 2 file(s) use "supportsave" command to upload
Resolution
Ein Softwarefehler in Routing-Services führte zu dem Ausfall, der Brocade-Defekt DEFECT000440968.
Die Lösung für das Problem besteht darin, den Switch auf FOS 7.4.x und höher zu aktualisieren.
Affected Products
ConnectrixArticle Properties
Article Number: 000055899
Article Type: Solution
Last Modified: 30 Aug 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.