SourceOne Email Management: Při převodu indexů ISYS nebo při vytvoření nové složky měsíce vytvoří nástroj SourceOne více než 1 index ElasticSearch.

Summary: Při převodu indexů ISYS nebo při vytvoření nové složky měsíce vytvoří nástroj SourceOne více než 1 index ElasticSearch.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Tento problém se může mírně lišit v závislosti na faktorech prostředí a nastavení konfigurace. Několik indexů ISYS by se mělo převést do jednoho indexu ElasticSearch a pouze v případě, že by se určitá prahová hodnota vypočítaná na základě různých faktorů (počet zpráv, počet svazků, vlastní nastavení ve složce Archiv atd.) měla přenést do nového ElasticSearch. Index ElasticSearch obvykle naroste až na několik GB, než se převede na další index ElasticSearch.

Elasticsearch představuje problémy s výkonem, když datové uzly překročí 500 horizontálních oddílů. Čím více uživatel překročí tuto hodnotu, tím větší je problém s výkonem a zvyšuje se pravděpodobnost výskytu níže vysvětlených problémů:
 

1.- Uživatel převádí indexy ISYS na ElasticSearch.
Uživatel převádí indexy ISYS na ElasticSearch a nástroj SourceOne během převodu vytvoří několik indexů ElasticSearch. Většina těchto indexů bude menší než 1 GB a poslední vytvořený index bude obsahovat většinu dat převedených z ISYS.
 
2. – Uživatel, který spouští aktivity zaznamenávání deníku nebo historické archivace, si všimne, že nástroj SourceOne vytvoří při vytvoření nové složky měsíce 2 indexy ElasticSearch.
Uživatel uvidí v nově vytvořené složce month 2 indexy ElasticSearch: 1 Index bude obsahovat pouze několik MB informací a další Index bude obsahovat většinu dat přidávaných do složky month.

Cause

Tento problém je způsoben softwarovou závadou

. Může jít o potíže s výkonem v clusteru ElasticSearch a v prostředí, na kterém běží více než 1 archivní server.
Tento problém je způsoben tím, že více než 1 archivní server přijme transakční soubor (xvlts) nebo soubor .convert (převod ISYS na ElasticSearch) a problémy s výkonem ElasticSearch způsobí zpoždění při vytváření indexu v clusteru. Tím se vytvoří dostatečné okno, během kterého by jiný server mohl vybrat soubor transakce a určit, že je potřeba nový index ES, což může vést k dalším indexům.

Resolution

Tento problém bude vyřešen opravami nebo verzemi Service Pack EMC SourceOne Email Management po verzi 7.2.7.7034 (HFB2).

Balíčky oprav hotfix a sady Service Pack jsou k dispozici ke stažení prostřednictvím https://www.dell.com/support.
* Opravy hotfix jsou k dispozici pouze pro nejaktuálnější verze oprav nebo aktualizací Service Pack produktu, které byly k dispozici v době vyřešení tohoto problému.
** Upozorňujeme, že vždy doporučujeme provést upgrade na nejnovější verzi softwaru SourceOne, aktualizaci Service Pack a sadu oprav hotfix, aby byly odstraněny všechny aktuálně vyřešené problémy včetně výše uvedeného problému

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000055966
Article Type: Solution
Last Modified: 26 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.