SourceOne Email Management : SourceOne crée plusieurs index ElasticSearch lors de la conversion d’index ISYS ou lors de la création d’un nouveau dossier mois.
Summary: SourceOne crée plusieurs index ElasticSearch lors de la conversion d’index ISYS ou lors de la création d’un nouveau dossier mois.
Symptoms
Ce problème peut être observé légèrement différemment en fonction des facteurs environnementaux et des paramètres de configuration. Plusieurs index ISYS doivent être convertis en un seul index ElasticSearch et ce n’est que lorsqu’un certain seuil calculé en fonction de différents facteurs (nombre de messages, nombre de volumes, paramètres personnalisés dans le dossier Archive, etc.) doit être transféré vers un nouvel ElasticSearch. En général, l’index ElasticSearch augmente jusqu’à plusieurs Go avant d’être transféré à l’index ElasticSearch suivant.
ElasticSearch présente des problèmes de performances lorsque les nœuds de données dépassent 500 Shards. Plus un utilisateur dépasse cette valeur, plus le problème de performances est important et les chances de rencontrer les problèmes décrits ci-dessous augmentent.
2.- L’utilisateur exécutant des activités de journalisation ou d’archivage historique observe que SourceOne crée 2 index ElasticSearch lors de la création d’un nouveau dossier mois.
Cause
logiciel Il peut être causé par des problèmes de performances dans le cluster ElasticSearch et l’environnement exécutant plusieurs serveurs d’archivage.
Ce problème se produit lorsque plusieurs serveurs d’archivage récupèrent un fichier de transaction (xvlts) ou un fichier .convert (conversion ISYS vers ElasticSearch) et que les problèmes de performances d’ElasticSearch retardent la création de l’index dans le cluster. Cela crée une fenêtre suffisante pendant laquelle un autre serveur peut récupérer un fichier de transaction et déterminer qu’un nouvel index ES est nécessaire, ce qui peut entraîner des index supplémentaires.
Resolution
Les bundles de correctifs et les kits de correctifs peuvent être téléchargés via https://www.dell.com/support.
* Veuillez noter que les correctifs ne sont disponibles que pour les versions de correctif ou de Service Pack les plus récentes du produit qui étaient disponibles lorsque ce problème a été résolu.
** Notez qu’il est recommandé de toujours effectuer une mise à niveau vers la version supérieure de SourceOne, le correctif et l’offre groupée de correctifs pour s’assurer que tous les problèmes actuellement résolus seront corrigés, y compris le problème mentionné ci-dessus