SourceOne Email Management: SourceOne skapar mer än ett ElasticSearch-index vid konvertering av ISYS-index eller när en ny månadsmapp skapas.

Summary: SourceOne skapar mer än ett ElasticSearch-index vid konvertering av ISYS-index eller när en ny månadsmapp skapas.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Det här problemet kan ses lite annorlunda beroende på miljöfaktorer och konfigurationsinställningar. Flera ISYS-index bör konverteras till ett enda ElasticSearch-index och endast när ett visst tröskelvärde som beräknas baserat på olika faktorer (antal meddelanden, antal volymer, anpassade inställningar i arkivmappen osv.) ska rullas över till ett nytt ElasticSearch. Vanligtvis växer ElasticSearch-indexet upp till flera GB innan det återställs till nästa ElasticSearch-index.

ElasticSearch ger prestandaproblem när datanoder överskrider 500 shards. Ju mer en användare överskrider det här värdet, desto större blir prestandaproblemet och det ökar risken för att uppleva de problem som förklaras nedan:
 

1.- Användaren konverterar ISYS-index till ElasticSearch.
Användaren konverterar ISYS-index till ElasticSearch och ser att SourceOne skapar flera ElasticSearch-index under konverteringen. De flesta av dessa index kommer att vara mindre än 1 GB i storlek och det senaste indexet som skapas kommer att innehålla de flesta data som konverterats från ISYS.
 
2.- Användare som kör journalförings- eller historiska arkivaktiviteter observerar att SourceOne skapar 2 ElasticSearch-index när en ny månadsmapp skapas.
Användaren kommer att se 2 ElasticSearch-index i den nyskapade månadsmappen: 1 Index kommer bara att innehålla några få MB information och nästa index kommer att innehålla det mesta av de data som läggs till i månadsmappen.

Cause

Det här problemet orsakas av ett programvarufel

Problemet kan orsakas av prestandaproblem i ElasticSearch-klustret och miljön som kör fler än 1 arkivserver.
Det här problemet orsakas när fler än en arkivserver hämtar en transaktionsfil (xvlts) eller en .convert-fil (ISYS-konvertering till ElasticSearch) och prestandaproblemen med ElasticSearch orsakar en fördröjning när indexet skapas i klustret. Det skapar ett tillräckligt fönster under vilket en annan server kan hämta en transaktionsfil och fastställa att ett nytt ES-index behövs, vilket kan resultera i extra index.

Resolution

Det här problemet kommer att lösas i korrigeringsfiler eller Service Pack-versioner av EMC SourceOne Email Management post 7.2.7.7034 (HFB2)

Snabbkorrigeringspaket och Service Pack-paket kan laddas ner via https://www.dell.com/support.
* Observera att snabbkorrigeringar endast är tillgängliga för de senaste korrigerings- eller Service Pack-versionerna av produkten som var tillgängliga när det här problemet löstes.
** Obs! Vi rekommenderar alltid att du uppgraderar till den senaste versionen av SourceOne-utgåvan, Service Pack-paketet och snabbkorrigeringspaketet för att säkerställa att alla för närvarande lösta problem åtgärdas, inklusive det problem som anges ovan

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000055966
Article Type: Solution
Last Modified: 26 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.