Avamar:NetApp 备份已完成,但卷处于离线状态
Summary: NetApp 卷处于离线状态且无法访问,导致备份完成并出现异常。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
备份完成,但有异常
NetApp 备份会因异常而完成,指示访问某些卷时出现问题。
在 avndmp 日志中观察到以下错误消息:
2017-06-15 18:18:43 avndmp Error <0000>: [snapup-/vol/list_man_data] Volume: /vol/list_man_data is offline and cannot be accessed. (Log #3) 2017-06-15 18:18:43 avndmp Error <0000>: [snapup-/vol/list_man_data] Nothing to backup. Target list is empty. (Log #3) 2017-06-15 18:18:43 avndmp Error <0000>: [snapup-/vol/list_mail_archive] Volume: /vol/list_mail_archive is offline and cannot be accessed. (Log #3) 2017-06-15 18:18:43 avndmp Error <0000>: [snapup-/vol/list_mail_archive] Nothing to backup. Target list is empty. (Log #3) 2017-06-15 18:18:44 avndmp Error <0000>: [snapup-/vol/list_data] Volume: /vol/list_data is offline and cannot be accessed. (Log #3) 2017-06-15 18:18:44 avndmp Error <0000>: [snapup-/vol/list_data] Nothing to backup. Target list is empty. (Log #3)
Cause
问题的根本原因
此问题的根本原因与 NetApp 卷脱机但仍对 Network Data Management Protocol ( NDMP 可见)的处理方式有关。
借助 NetApp,卷可以离线,但可以通过 NDMP 协议查看卷。当 Avamar NDMP 浏览 NetApp 数据移动器时,将返回在线卷和离线卷。
当 NDMP 请求离线卷的转储时,将返回一个错误,如 avndmp 日志消息中所示:
2017-06-15 18:18:43 avndmp Error <0000>: [snapup-/vol/list_man_data] Volume: /vol/list_man_data is offline and cannot be accessed. (Log #3) 2017-06-15 18:18:43 avndmp Error <0000>: [snapup-/vol/list_man_data] Nothing to backup. Target list is empty. (Log #3)
导致该病因的关键因素。
- 卷离线但仍然对 NDMP 协议可见
- Avamar NDMP 浏览 NetApp 数据移动器并返回联机卷和脱机卷
- NDMP 请求离线卷的转储并返回错误
Resolution
解决 Avamar NDMP NetApp 备份异常
要解决 Avamar NDMP NetApp 备份完成但由于卷离线而出现异常的问题,NetApp 管理员必须执行特定步骤。
NetApp 管理员必须完全删除不存在的卷,而不仅仅是将其脱机。或者,他们可以修改配置,以便离线卷不会呈现给 NDMP 协议。
Affected Products
AvamarProducts
Avamar, Avamar Plug-in for NDMPArticle Properties
Article Number: 000056078
Article Type: Solution
Last Modified: 07 Aug 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.